Expose an API for Tab Candy groups

RESOLVED DUPLICATE of bug 697959

Status

P3
normal
RESOLVED DUPLICATE of bug 697959
8 years ago
3 years ago

People

(Reporter: iangilman, Unassigned)

Tracking

unspecified
Future

Details

(Reporter)

Description

8 years ago
For sessionstore (bug 588217) and add-on developers, we should expose an API to be aware of be able to manipulate Tab Candy groups. This will likely come out of the groups.jsm work required for bug 578512.
Blocks: 588217
Wearing my add-on developer hat, here are a couple of things I've wanted to do:

* Insert temporary (read-only?) groups from external sources. (api for adding groups)

* Sync/save groups to some external source. (api for getting groups)

* Make a keyboard shortcut that switches the active group in the current window *without* ever opening the panorama UI, eg, an alt+tab for groups. (api for switching active group)
Priority: -- → P3

Comment 2

8 years ago
Ian, when do you think this should land? Beta 9? After Firefox 4?

Comment 3

8 years ago
Punting to the future as it seems to be dependent on bug 578512.
Target Milestone: --- → Future
(Reporter)

Comment 4

8 years ago
Yeah, I think it's too late to make big changes to our API before FF 4.0
No longer blocks: 588217
Keywords: dev-doc-needed
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697959
Keywords: dev-doc-needed
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.