Go Next Unread Message doesn't work across folders in Message Window

RESOLVED DUPLICATE of bug 542161

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 542161
8 years ago
8 years ago

People

(Reporter: Shadow912, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100819 Shredder/3.2a1pre Build ID: 20100819033932

When some unread messages in different folders, Click [Next] button, press N or choose Go > Next > Unread message doesn't work in Message Window.

On error console:
==========
Error: An error occurred executing the cmd_nextUnreadMsg command: [Exception... "'[JavaScript Error: "SelectFolder is not defined" {file: "chrome://messenger/content/msgViewNavigation.js" line: 242}]' when calling method: [nsIController::doCommand]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 96"  data: yes]
Source file: chrome://global/content/globalOverlay.js
Line: 100
==========

Reproducible: Always

Steps to Reproduce:
1.Mark unread flag for some messages in different folders
2.Open Message Window
3.Click [Next] button, press N or choose Go > Next > Unread message
Actual Results:  
Do nothing...

Expected Results:  
Show next unread message

N.G.:
Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100819 Shredder/3.2a1pre Build ID: 20100819033932
Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.2.8) Gecko/20100802 Thunderbird/3.1.2 Build ID: 20100802165400
Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.1.11) Gecko/20100711 Thunderbird/3.0.6 Build ID: 20100711065956(No warnings and errors on error console)

OK:
Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.8.1.24) Gecko/20100228 Thunderbird/2.0.0.24 Build ID: 2010022820
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542161
You need to log in before you can comment on or make changes to this bug.