Closed Bug 589389 Opened 9 years ago Closed 9 years ago

Enable plugins for MOZ_PLATFORM_MAEMO by default

Categories

(Firefox for Android Graveyard :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: jap, Assigned: jap)

References

Details

Attachments

(1 file, 4 obsolete files)

Plugins should be enabled for MOZ_PLATFORM_MAEMO == 6.
Attachment #468000 - Flags: review?(mark.finkle)
Summary: Enable plugins for MOZ_PLATFORM_MAEMO == 6 by default → Enable plugins for MOZ_PLATFORM_MAEMO by default
Attached patch Updated patch v2 (obsolete) — Splinter Review
Hm, the preprocessor script does not support to check for platform version.
Attachment #468000 - Attachment is obsolete: true
Attachment #468014 - Flags: review?(mark.finkle)
Attachment #468000 - Flags: review?(mark.finkle)
Attachment #468014 - Attachment is obsolete: true
Attachment #468106 - Flags: review?(mark.finkle)
Attachment #468014 - Flags: review?(mark.finkle)
Why only maemo 6? Won't maemo 5 work too? What platform changes landed to make this work (got a bug#)?
(In reply to comment #4)
> Why only maemo 6? Won't maemo 5 work too? What platform changes landed to make
> this work (got a bug#)?

I tried only with patch from bug 556487 in maemo 6. Setted it as a dependency, since it did not land yet. Maemo 5 should also work with that patch, but should better be tested.
Depends on: 556487
(In reply to comment #2)
> Created attachment 468014 [details] [diff] [review]
> Updated patch v2
> 
> Hm, the preprocessor script does not support to check for platform version.

The text preprocessor does support this, but it's very strict. No spaces around the operators:

#if MOZ_PLATFORM_MAEMO==6

But if maemo 5 works too, then we should skip the version check.
Actually, bug 556487 seems to work for desktop builds too, if I'm not mistaken. If Android is the only platform plugins won't work correctly, let's switch the logic around in the patch:

#if ANDROID
// disable plugins
#else
// enable plugins
#endif
Attachment #468106 - Flags: review?(mark.finkle) → review-
Attachment #468106 - Attachment is obsolete: true
Attachment #468799 - Flags: review?(mark.finkle)
Comment on attachment 468799 [details] [diff] [review]
Updated patch v4 (Disable plugins only for android)

"plugin.default_plugin_disabled" was removed in bug 533891. We don't need it anymore.

r+ with that change. Can you make a new patch so we can land this when the plugin patches land?
Attachment #468799 - Flags: review?(mark.finkle) → review+
tracking-fennec: --- → 2.0+
Attachment #468799 - Attachment is obsolete: true
Attachment #469782 - Flags: review?(mark.finkle)
Attachment #469782 - Flags: review?(mark.finkle) → review+
removed dependency, its not really blocking this
No longer depends on: 556487
pushed (finally):
http://hg.mozilla.org/mobile-browser/rev/8c1f1f97a366
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 596432
Verified fixed. I've seen it in the hg log, the fix for bug 625673 changed things further, so you can't really recognize this fix anymore in mxr.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.