[SeaMonkey 2.1, mochitest-browser-chrome] browser_Services.js | Services.search exists

VERIFIED FIXED in mozilla2.0b7

Status

()

Core
General
--
major
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: Robert Kaiser, Assigned: Ian Neal)

Tracking

(Blocks: 1 bug, {intermittent-failure})

Trunk
mozilla2.0b7
intermittent-failure
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sm-perma])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1282499502.1282502435.6363.gz

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_Services.js | Services.search exists
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_Services.js | Services.search is an nsIBrowserSearchService

The test for Services.search should only be executed when OpenSearch is built.
(Reporter)

Updated

8 years ago
Blocks: 452942
Unexpected, bug 553815 was supposed to fix (all the issue of) this test...
Depends on: 553815
(Reporter)

Comment 2

8 years ago
My guess is that the test for the interface in the test now always succeeds as the components are registered differently.
> My guess is that the test for the interface in the test now always succeeds as
> the components are registered differently.

yea, that would be the case... I'll have to dive back into this(In reply to comment #2)
Fwiw,
http://brasstacks.mozilla.com/topfails/test/SeaMonkey?name=chrome://mochikit/content/browser/toolkit/content/tests/browser/browser_Services.js
"2010-05-27 13:34": when this test was fixed previously.
"2010-08-14 10:19": when it started failing again.
(Assignee)

Comment 6

8 years ago
I'm guessing some of the new code should have some ifdefs round it?
(Reporter)

Comment 7

8 years ago
Hah, well, he made the IDL to be built even when the toolkit search service is not built - there you have it.
(Assignee)

Comment 8

8 years ago
Created attachment 472040 [details] [diff] [review]
ifdef bits out patch v0.1

Patch to ifdef out toolkit search code if toolkit search is not enabled
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #472040 - Flags: review?(gavin.sharp)
Comment on attachment 472040 [details] [diff] [review]
ifdef bits out patch v0.1

>diff --git a/netwerk/base/public/Makefile.in b/netwerk/base/public/Makefile.in

>-		nsIRedirectResultListener.idl \
>-		nsIBrowserSearchService.idl \
>-		$(NULL)
>+		nsIRedirectResultListener.idl
>+
>+ifdef MOZ_TOOLKIT_SEARCH
>+XPIDLSRCS	+= nsIBrowserSearchService.idl
>+endif
>+
>+XPIDLSRCS	+= $(NULL)

This doens't look right - AFAIK $(NULL)'s only purpose is to serve as a dummy end marker to ensure that all entries end with "\", so that adding/removing entries doesn't require editing two lines. So you should just leave the $(NULL) at the end of the other block - as in e.g. http://mxr.mozilla.org/mozilla-central/source/embedding/browser/webBrowser/Makefile.in#75 . r=me with that fixed.
Attachment #472040 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

8 years ago
Component: Testing Infrastructure → General
Product: SeaMonkey → Core
QA Contact: testing-infrastructure → general
Target Milestone: --- → mozilla2.0b6
(Assignee)

Comment 10

8 years ago
Created attachment 472053 [details] [diff] [review]
Only build search code when MOZ_TOOLKIT_SEARCH is enabled patch v0.1a [Backed out: Comment 14]

Changes since v0.1:
* Fixed Makefile.in as suggested by reviewer.

Requesting a= for simple, low risk patch that fixes an issue with moved code (and helps remove an orange on SM tests)
Attachment #472040 - Attachment is obsolete: true
Attachment #472053 - Flags: review+
Attachment #472053 - Flags: approval2.0?
Comment on attachment 472053 [details] [diff] [review]
Only build search code when MOZ_TOOLKIT_SEARCH is enabled patch v0.1a [Backed out: Comment 14]

Hrmn actually this should have implicit a+ as "NPOTB" (since Firefox builds with BrowserSearchService of course)
Attachment #472053 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 12

8 years ago
Comment on attachment 472053 [details] [diff] [review]
Only build search code when MOZ_TOOLKIT_SEARCH is enabled patch v0.1a [Backed out: Comment 14]

http://hg.mozilla.org/mozilla-central/rev/2a216165e361
Attachment #472053 - Attachment description: Only build search code when MOZ_TOOLKIT_SEARCH is enabled patch v0.1a → Only build search code when MOZ_TOOLKIT_SEARCH is enabled patch v0.1a [Checked in: Comment 12]
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
V.Fixed, per
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1284130726.1284133745.30739.gz
Linux comm-central-trunk debug test mochitest-other on 2010/09/10 07:58:46
Severity: normal → major
Status: RESOLVED → VERIFIED
Flags: in-testsuite-

Updated

8 years ago
Depends on: 595509
Backed out because this caused bug 595509 (MOZ_TOOLKIT_SEARCH isn't AC_DEFINED).

https://hg.mozilla.org/mozilla-central/rev/84baf90b040c
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
IanN, on Bug 595509 (attachment 474379 [details] [diff] [review]) I provided a fix. Wish it was taken instead of a backout though. But lets get this (back) in!
err home network fail :/

the fix was adding DEFINES += -DMOZ_TOOLKIT_SEARCH in the makefile at docshell/base/ conditional on ifdef MOZ_TOOLKIT_SEARCH

I can attach the fix here later.
(Assignee)

Updated

8 years ago
Attachment #472053 - Attachment description: Only build search code when MOZ_TOOLKIT_SEARCH is enabled patch v0.1a [Checked in: Comment 12] → Only build search code when MOZ_TOOLKIT_SEARCH is enabled patch v0.1a [Checked in: Comment 12] [Backed out: Comment 14]
(Assignee)

Comment 17

8 years ago
Created attachment 474432 [details] [diff] [review]
Only build search code when MOZ_TOOLKIT_SEARCH is fully defined patch v0.2 [Checked in: Comment 20]

As MOZ_TOOLKIT_SEARCH is not AC_DEFINED need to add it to the Makefile.in
Used test from bug 595509 to check without any patch applied (PASS), with old patch applied (FAIL), with this patch applied (PASS).
Attachment #474432 - Flags: review?(gavin.sharp)
Comment on attachment 474432 [details] [diff] [review]
Only build search code when MOZ_TOOLKIT_SEARCH is fully defined patch v0.2 [Checked in: Comment 20]

This Makefile change is what my "empty patch" was intended to be in the other bug.
Attachment #474432 - Flags: review+
Attachment #474432 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

8 years ago
Attachment #474432 - Flags: approval2.0?
(Reporter)

Comment 19

8 years ago
The ideal fix would be to get in bug 410613 on the SeaMonkey side :P
(Assignee)

Comment 20

8 years ago
Comment on attachment 474432 [details] [diff] [review]
Only build search code when MOZ_TOOLKIT_SEARCH is fully defined patch v0.2 [Checked in: Comment 20]

http://hg.mozilla.org/mozilla-central/rev/da8dd922ba0c
a=NPOTB
Attachment #474432 - Attachment description: Only build search code when MOZ_TOOLKIT_SEARCH is fully defined patch v0.2 → Only build search code when MOZ_TOOLKIT_SEARCH is fully defined patch v0.2 [Checked in: Comment 20]
Attachment #474432 - Flags: approval2.0?
(Assignee)

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
V.Fixed, per
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1284821028.1284823562.22253.gz
OS X 10.5 comm-central-trunk debug test mochitest-other on 2010/09/18 07:43:48
Status: RESOLVED → VERIFIED
Attachment #472053 - Attachment description: Only build search code when MOZ_TOOLKIT_SEARCH is enabled patch v0.1a [Checked in: Comment 12] [Backed out: Comment 14] → Only build search code when MOZ_TOOLKIT_SEARCH is enabled patch v0.1a [Backed out: Comment 14]
Attachment #472053 - Attachment is obsolete: true
Keywords: intermittent-failure
Whiteboard: [sm-perma][orange] → [sm-perma]
You need to log in before you can comment on or make changes to this bug.