Closed Bug 595509 Opened 11 years ago Closed 11 years ago

default search no longer working in location bar

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 4.0b7
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: beltzner, Assigned: Gavin)

References

Details

(Keywords: regression)

Attachments

(2 files, 4 obsolete files)

Regressed somewhere between Sept 10 and Sept 11 nightlies:

Steps to reproduce:
1. Type "sad face" in the location bar
2. Hit enter

Expected: http://www.google.ca/search?q=sad+face&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=firefox-a

Actual: JS alert "The URL is not valid and cannot be loaded."
Adding Gavin, as he touched this last, but not sure what could have happened in the past few days to make this go away.

(Also adding Jono, in case this was one of the prefs that Test Pilot might have overwritten)
blocking2.0: --- → beta6+
Keywords: regression
Happens on XP and Mac as well.
OS: Windows 7 → All
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cca361001fda&tochange=2a216165e361
Bug 589613 - [SeaMonkey 2.1, mochitest-browser-chrome] browser_Services.js | Services.search exists
Blocks: 589613
Attached patch Fix [Empty diff] (obsolete) — Splinter Review
Sorry...

I will be unable to land this until monday or tuesday night, so feel free to push on my behalf. And if this needs a test, Tuesday night is earliest.
Assignee: nobody → bugspam.Callek
Status: NEW → ASSIGNED
Attachment #474379 - Flags: review?(gavin.sharp)
Hardware: x86 → All
Version: unspecified → Trunk
Attachment #474379 - Attachment description: Fix → Fix [Empty diff]
Attachment #474379 - Attachment is obsolete: true
Attachment #474379 - Flags: review?(gavin.sharp)
Attached patch test (obsolete) — Splinter Review
Assignee: bugspam.Callek → gavin.sharp
I fixed this by backing out 589613.

https://hg.mozilla.org/mozilla-central/rev/84baf90b040c
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Attached patch testSplinter Review
I made sure that this doesn't actually depend on the network (works even if the page fails to load).
Attachment #474387 - Attachment is obsolete: true
Attachment #474389 - Flags: review?(dao)
Not sure if this is the best way of resolving the issue of when the Alert is triggered, but I did notice that if the Alert is left open then the test eventually generates a mini-dump.
Attachment #474405 - Flags: review?(gavin.sharp)
Attachment #474405 - Flags: review?(gavin.sharp)
Attachment #474405 - Attachment is obsolete: true
Attachment #474389 - Flags: review?(dao) → review+
Comment on attachment 474406 [details] [diff] [review]
Test that does not crash / timeout when it fails v0.1 (once refreshed)

This needs to unregisterNotification in the success case, otherwise it will likely interfere with other tests.
Changes since v0.1:
* Unregister observer in success case;
* Use "this" instead of "listener" in ProgressListener removal.
Attachment #474406 - Attachment is obsolete: true
Attachment #474441 - Flags: review?(gavin.sharp)
Attachment #474441 - Flags: review?(gavin.sharp)
Attachment #474441 - Flags: review+
Attachment #474441 - Flags: approval2.0+
Comment on attachment 474441 [details] [diff] [review]
Test that does not crash / timeout when it fails with observer unregister patch v0.2 [Checked in: Comment 12]

http://hg.mozilla.org/mozilla-central/rev/28ff9550b120
Attachment #474441 - Attachment description: Test that does not crash / timeout when it fails with observer unregister patch v0.2 → Test that does not crash / timeout when it fails with observer unregister patch v0.2 [Checked in: Comment 12]
Target Milestone: --- → Firefox 4.0b7
You need to log in before you can comment on or make changes to this bug.