Selecting custom sound for incoming mail does not work

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: mike.cloaked, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.127 Safari/533.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.9pre) Gecko/20100821 Lanikai/3.1.3pre

In Edit->Preferences->General selecting the check for "Play a sound" and "Use the following file" does not gives any response when clicking "Play", nor does it work when new mail arrives (it gives a system beep instead!)

Reproducible: Always

Steps to Reproduce:
1. Select Edit->Preferences->General
2. Check "Play a sound"under "When new messages arrive"
3. Check "Use the following file"
4. Navigate to a xxx.wav file
5. Click the play icon, and wait for incoming email
Actual Results:  
The Play icon gives no response (no sound), and when new mail arrives there is only a system beep, and the .wav file is not played.

Expected Results:  
The Play button should play the xxx.wav file, and the same file should plahy when new email arrives

Using "aplay xxx.wav" in a terminal window plays the file just fine.
This is in a newly updated Fedora F13 system running kernel 2.6.33.6-147.2.4.fc13.i686.PAE, and using the gnome desktop.

I have had another user with the analogous system confirm that he gets the same symptoms as me. Also tested with the stock version of Thunderbird in this computer (thunderbird-3.1.2-1.fc13.i686) and the same problem occurs.

The sound settings have all been checked using both alsamixer -c 0 and also using pavucontrol to check the pulseaudio settings and there is no other observed problem with the sound system.
Do you get any error message in TB's error console?

Do you have a package called pulseaudio-esound-compat or similar?
(Reporter)

Comment 2

8 years ago
I have installed pulseaudio-esound-compat and indeed also made a symlink from /usr/bin/esdcompat to /usr/bin/esd and rebooted but this makes no difference.

The TB error console contains no messages of relevance.
(Reporter)

Comment 3

8 years ago
I have now tested on a separate laptop also running Fedora F13 with the gnome desktop, and the stock version (Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2.8) Gecko/20100802 Lightning/1.0b2 Thunderbird/3.1.2) and the exact same symptoms occur as reported above. Also tested pulseaudio-esound-compat and this does not fix the problem.
(Reporter)

Comment 4

8 years ago
One way to get this operational would be to add an additional option to execute a command as well choosing to  "Play" the selected file.  If this was the case then being able to select a command such as "aplay xxx.wav" would get this going. It would mean adding code to do this but perhaps this might be quicker than triaging the bug? The bug should fixed as well of course!

Comment 5

8 years ago
I see same problem - add an explicit .wav file as my choice.

Then click 'play' button to test. No sound.

I do however see this in the error console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISound.play]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/preferences/general.js :: anonymous :: line 94"  data: no]


I am running fully updated fedora 13 and this version of tb:

 3.1.3pre build ID: 20100816204311

Comment 6

8 years ago
Forgot to say - sound works fine - and I can 'aplay' the same .wav file directly - it is only thunderird which has a problem.

Aside: esd is deprecated - perhaps TB has yet to be taught how to interact with pulseaudio ?
Is there anyone not using Fedora 13 where it fails?

I just tried a new Gnome based installation of openSUSE 11.3 (with pulseaudio enabled) and it just works out of the box.

Do you guys have /usr/lib/libesd.so.0 on your system?
(Reporter)

Comment 8

8 years ago
I don't see /usr/lib/libesd.so.0 even if pulseaudio-esound-compat is installed!
So that's it in your case (most likely).
pulseaudio-esound-compat does not depend on libesd and so is Thunderbird not hard depending on libesd. It uses it only if installed. Check which package on Fedora 13 is providing it and install. Should fix your issue.
(Reporter)

Comment 10

8 years ago
Created attachment 468302 [details]
.wav file used in the bug report that does not play for incoming mail

This is the file that I am attempting to play for incoming mail sound
(Reporter)

Comment 11

8 years ago
Ahh - OK - thank you - that is helpful - it seems that libesd.so.0 needs the package "esound-libs" installing - I will do that when I get back to both machines this evening and report back.

Comment 12

8 years ago
yes indeed There is no /usr/lib/libesd.so.0 ... 

it has been deprecated as far as I can tell sometime early last year.

There is a package esound-libs which looks to provide it .. but this seems to be slated to die .. 

Is it possible for thunderbird to be updated to use the newer audio system ?

I will install esound-libs and confirm if it works or not shortly.

Comment 13

8 years ago
Installing esound-libs makes no difference - nor does it install the /usr/lib/libesd.so.0.

The reason is prehaps explained by this element from the changelog:


* Fri Oct 26 2007 - Bastien Nocera <bnocera@redhat.com> - 1:0.2.38-6
- Kill the main esound package, so people don't try to use it instead of
  pulseaudio itself (#353051)


So - esd has been deprecated totally - looks like its time for pulse :D
(Reporter)

Comment 14

8 years ago
On one of the systems here having installed esound-libs and then logging out and back in, and restarting Thunderbird this fixes the problem for me. So on this one system having the additional package does work.

I will test my other system on my laptop this evening and check if it works there and report back later.

Comment 15

8 years ago
Of note - I restarted tb but I did not reboot after installing esound-libs.

Comment 16

8 years ago
Ah .. while there is no /usr/lib/libesd.so.0 .. there IS a /usr/lib64/libesd.so.0 (:D)

Aside - there is no fedora 13 package for this only fedora 12 - not sure that makes much difference here.

However it did not work for me on x86_64 bit install (I did not reboot or relogin - I will check later if that makes any difference).

I have installed:

   pulseaudio-esound-compat.x86_64 0:0.9.21-6.fc13
   esound-libs-0.2.41-3.fc12.x86_64

I get exactly the same error in the error console as earlier

Even tho/if it works ... I'd still urge tb to switch to pulse for audio ..
(Reporter)

Comment 17

8 years ago
Yes could be that additional packages are needed for 64 bit?  In my case the systems are both 32 bit!  I did not need to reboot, only to restart the session.

Comment 18

8 years ago
Good catch Mike Cloaked - tb is indeed 32 bit (no 64 bit builds yet for 3.1 series) ...

After installing the 32 bit version of esound-libs indeed sound works.

Thanks - both of you.

(Still nudging for update to pulse so we dont need to install compat libs for deprecated system .. :D)
Note: the 3.1.3pre builds do not yet have the fix that was in 3.1.2 for sound on Linux (bug 579877).
(Reporter)

Comment 20

8 years ago
OK - this looks like being resolved now, but I will test my second system tonight and if sound works there as well, then I will change this to status resolved - thanks to Gene and to Wolfgang for getting the key pieces together to solve this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 21

8 years ago
I have now installed esound-libs on the second laptop and tested - it works fine.

On closing I would like to add my plea for Thunderbird to move from esd to pulse as part of the normal development of its sound support.
You need to log in before you can comment on or make changes to this bug.