If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The contextual menu does not always appear on right click

VERIFIED FIXED

Status

()

Core
Widget: Cocoa
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Pierre Bertet, Unassigned)

Tracking

unspecified
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [fixed by bug 130078])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; fr; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5pre) Gecko/20100822 Minefield/4.0b5pre

The contextual menu sometimes fails to appear on first right click.

Reproducible: Always

Steps to Reproduce:
1. Open two tabs and load example.com
2. On first tab, select a word (double left click) and right click on it
3. On the second tab, select a word (double left click) and right click on it
Actual Results:  
The contextual menu does not appear.

Expected Results:  
The contextual menu should appear.

Tested on OS X 10.6, with Firefox 3.6 and Minefield 20100822.

If I’m waiting 1 sec. between the selection and the right click, the contextual menu is appearing as expected.
Looks like to be an OS X only bug. Works fine for me with a build on Windows. Josh or Steven, do you have an idea?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.6 Branch
I can reproduce this (in FF 3.6.8 and today's trunk, 1.9.2-branch and
1.9.1-branch nightlies, on OS X 10.5.8).

The bug is very strange.  It happens only "once", until you switch
tabs (then it happens only "once" again):  If you go through the steps
quickly enough, you can make it happen several times in a row.  But
after it's stopped happening, it won't happen again until you switch
tabs.

I'd guess this is some kind of focus issue, and/or possibly a timer
issue.  By testing near the edge of the browser window, I've found
that the context menu doesn't open behind the browser window -- it
doesn't open at all.  Beyond that I can't say.

Here's the regression range:

firefox-2006-09-28-08-trunk
firefox-2006-09-29-06-trunk

So this started happening as soon as Cocoa widgets was turned on.
Component: Menus → Widget: Cocoa
Product: Firefox → Core
QA Contact: menus → cocoa
Version: 3.6 Branch → unspecified
Blocks: 326469
At this very moment I can reproduce this problem on 4.0b6pre (Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6pre) Gecko/20100905 Firefox/4.0b6pre). I'm in the twitter.com/home page and I can bring up the context menu on some links but not in others.
blocking2.0: --- → ?

Comment 4

7 years ago
This is probably related to the "can only type in textareas for a bit, then I have to focus away and back again" thing, which *might* be bug 592563.
blocking2.0: ? → final+
> This is probably related to the "can only type in textareas for a
> bit, then I have to focus away and back again" thing, which *might*
> be bug 592563.

This bug (bug 589762) isn't related to bug 592563, though both are
focus bugs.  Bug 592563 has to do with plugins; this bug doesn't.
In fact I can no longer reproduce this bug on the trunk.

The last nightly in which I can reproduce it is
2010-08-27-03-mozilla-central.  So this bug must (I think) have been
fixed by the patch for bug 130078 (the same patch that triggered bug
592563).

What you're talking about, Marcia, must be a different bug.
Marcia -> Juan

Oops :-)
> So this bug must (I think) have been fixed by the patch for bug
> 130078 (the same patch that triggered bug 592563).

Specifically the part of the patch for bug 130078 that removed
subframe widgets.
Works fine for me too. Can't see it anymore with todays nightly build on OS X and the given steps in comment 0.
(Reporter)

Comment 10

7 years ago
Works for me too (Minefield 20100908).
Fixed by second part of patch for bug 130078 (which removed subframe widgets).
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Depends on: 130078
Whiteboard: [fixed by bug 130078]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.