Closed Bug 589876 Opened 10 years ago Closed 10 years ago

Switch-to-Tab fails to appear for tabs dragged to their own window

Categories

(Firefox :: Address Bar, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0b7

People

(Reporter: u279076, Assigned: mak)

References

Details

(Whiteboard: [switch-to-tab], [4b4])

Attachments

(1 file, 1 obsolete file)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5pre) Gecko/20100823 Minefield/4.0b5pre

This issue was originally brought to my attention via https://litmus.mozilla.org/single_result.cgi?id=290027

When you drag and drop a tab to its own window, it does not appear in Switch-to-Tab results in the awesomebar.

Steps to Reproduce:
1. Open a few tabs with different websites, make one of them digg.com
2. Open a new tab and type "digg" to verify the switch-to-tab result appears
3. Drag the Digg tab to the desktop
4. Go back to the main window
5. In the still open new tab, type "digg"

Result:
The switch-to-tab result no longer appears if the tab is dragged to its own window

Expected:
Switch-to-Tab result should appear for ALL open tabs
Whiteboard: [switch-to-tab]
Flags: in-litmus?
Whiteboard: [switch-to-tab] → [switch-to-tab], [4b4]
Is this the same issue described in bug 583694?
Attached patch patch v1.0 (obsolete) — Splinter Review
this should make it, not sure if I can write a simple enough test for it though, maybe I could emulate a detach and then synthesize a drop.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Comment on attachment 470632 [details] [diff] [review]
patch v1.0

I think I don't have time right now to write a complicated b-c test for this edge case... would it be fine to take the patch as is? I can eventually file a bug for the test if we feel like it's absolutely needed.
Attachment #470632 - Flags: review?(gavin.sharp)
A test that just calls swapBrowsersAndCloseOther (i.e. does a tab detach programmatically) would be better than nothing, even if it doesn't test the actual dragging code paths, right?
Duplicate of this bug: 558438
Comment on attachment 470632 [details] [diff] [review]
patch v1.0

r=me, but I think adding a test that calls swapBrowsersAndCloseOther to browser_tabMatchesInAwesomebar.js should be doable.
Attachment #470632 - Flags: review?(gavin.sharp) → review+
Attached patch patch v1.1Splinter Review
Added the requested test.
Attachment #470632 - Attachment is obsolete: true
Attachment #471783 - Flags: approval2.0?
Attachment #471783 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/3cd6ec7f86ff
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.