[Meta] Tweak Firefox menu a bit

RESOLVED FIXED

Status

()

Firefox
Menus
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Terepin, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100823 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100823 Minefield/4.0b5pre

1. Right-side section's items are placed lower then items in left-side section.
2. Hover effect of right-side section's items shouldn't touch middle separator.
3. Move submenu arrow in Developer little to the left, so it can be alligned with others.
4. Remove duplicated items in split-menus:
   4.1. New tab -> New tab
   4.2.  Print... -> Print...
   4.3. Options... -> Options...
   4.4. Help -> Help

Reproducible: Always
(Reporter)

Updated

7 years ago
Blocks: 583386

Comment 1

7 years ago
Your fourth item regarding "duplicates" is intentional. That is by design, and is done in exactly the same way in the right-click menus of Office 2007 and above.

Comment 2

7 years ago
Also, for your third item to be fixed, it will depend on bug 589146.
(Reporter)

Comment 3

7 years ago
(In reply to comment #1)
> Your fourth item regarding "duplicates" is intentional. That is by design, and
> is done in exactly the same way in the right-click menus of Office 2007 and
> above.

I'll ask again: What's the point of having duplicated items in Firefox Menu? We are trying to get rid all of duplications, yet we are want to keep them in menu? Am I missing something?
(Reporter)

Comment 4

7 years ago
(In reply to comment #2)
> Also, for your third item to be fixed, it will depend on bug 589146.

How so?
Component: Disability Access → Menus
QA Contact: disability.access → menus
Shifting this into separate bugs:

>1. Right-side section's items are placed lower then items in left-side section.

Bug 610773 - In the Firefox menu items in the right and left panes need to be vertically aligned

>2. Hover effect of right-side section's items shouldn't touch middle separator.

Bug 610830 - Menu items in the Firefox menu should have 2 pixels of padding on each side

>3. Move submenu arrow in Developer little to the left, so it can be alligned
with others.

This seems to be fixed now, not sure with which bug

>4. Remove duplicated items in split-menus:

This is intended, so that users who expand the menu looking for a command (not realizing that the main commands are active) can continue to move forward instead of having to fall back to the main menu.  Also this lets us expose keyboard shortcuts for the main menu items.
(Reporter)

Comment 6

7 years ago
A dupe then? Or meta?
whichever you prefer
(Reporter)

Comment 8

7 years ago
Thanks! Can you set it as New, please?
Depends on: 610773, 610830
Summary: Tweak Firefox menu a bit → [Meta] Tweak Firefox menu a bit
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.