XP specific styling of menu buttons in popup notifications

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Terepin, Assigned: Margaret)

Tracking

Trunk
All
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100823 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100823 Minefield/4.0b5pre

Someone from UX team should post a mockup.

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 577927
Version: unspecified → Trunk
Created attachment 469982 [details]
Windows XP Arrow Panel Design
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

8 years ago
Assignee: nobody → margaret.leibovic
(Assignee)

Comment 2

8 years ago
Created attachment 488046 [details] [diff] [review]
patch
Attachment #488046 - Flags: review?(dao)
(Assignee)

Comment 3

8 years ago
Created attachment 488047 [details]
screenshot

Updated

8 years ago
Summary: XP specific styling of Doorhanger → XP specific styling of menu buttons in popup notifications
(Assignee)

Comment 4

8 years ago
(In reply to comment #2)
> Created attachment 488046 [details] [diff] [review]
> patch

Note: I built this patch on top of the patch for bug 577928.
Depends on: 577928
Whiteboard: [needs review dao]
Comment on attachment 488046 [details] [diff] [review]
patch

>diff --git a/toolkit/themes/winstripe/global/notification.css b/toolkit/themes/winstripe/global/notification.css
>--- a/toolkit/themes/winstripe/global/notification.css
>+++ b/toolkit/themes/winstripe/global/notification.css
>@@ -58,68 +58,90 @@ notification[type="critical"] .messageIm
> }
> 
> /* Popup notification button */
> 
> .popup-notification-menubutton {
>   margin-top: 17px;
> }
> 
>-%ifdef WINSTRIPE_AERO

Use %ifdef XP_WIN here, since winstripe is the basis for various non-Windows toolkit themes.
Attachment #488046 - Flags: review?(dao) → review+

Updated

8 years ago
Component: Theme → Themes
Product: Firefox → Toolkit
QA Contact: theme → themes
(Assignee)

Comment 6

8 years ago
Created attachment 488055 [details] [diff] [review]
revised patch
Attachment #488046 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Attachment #488055 - Flags: approval2.0?
(Assignee)

Updated

8 years ago
Whiteboard: [needs review dao] → [can land]
Attachment #488055 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/8bc89d6577d7
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [can land]
You need to log in before you can comment on or make changes to this bug.