Adjust appearance of Doorhanger notification pop-up to match mockups

RESOLVED INVALID

Status

()

Firefox
Theme
RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: Terepin, Unassigned)

Tracking

(Depends on: 1 bug, {meta})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [doorhanger], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; sk; rv:2.0b2pre) Gecko/20100710 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; sk; rv:2.0b2pre) Gecko/20100710 Minefield/4.0b2pre

Currently is Doorhanger using rectangle with no specific styling for each platform. We need to change it for Windows, Linux and Mac.

See URL for mockups.

Reproducible: Always
(Reporter)

Updated

8 years ago
Depends on: 577928
(Reporter)

Updated

8 years ago
Depends on: 577930
(Reporter)

Updated

8 years ago
Depends on: 577931
(Reporter)

Updated

8 years ago
Depends on: 554937
(Reporter)

Updated

8 years ago
Blocks: 398776
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
Blocks: 551861
As soon as the blocker bug 554937 is resolved we need to start work on this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
No longer blocks: 551861
Blocks: 588240
Summary: [Meta] Adjust appearance of Doorhanger notification pop-up to match mockups → Adjust appearance of Doorhanger notification pop-up to match mockups
Blocking because it blocks a blocker.
blocking2.0: ? → betaN+
Leaving this as a blocker for now, but the course of action isn't exactly clear, beyond the bug on arrow panels.

The other dependencies all just seem to be tracking bugs. It would be great if for each of those we could get:

 - the list of essential changes to make
 - the list of nice to have changes to make
(Reporter)

Comment 4

7 years ago
This was originally meta bug, but someone changed that. (And I have absolutely no idea why.)
> but someone changed that

I wanted to be able to pick up blocking.  Also this is more a defined set of changes than a bug for other people to attach anything related that they find to.

>- the list of essential changes to make

We are looking for getting these to match the mockups that Stephen created.  He can provide image files.  For XP/Linux/OS X this is very straightforward.  Windows 7 is a bit more complex (with the glass border we may need bug 578780 for the arrow).  We can go with more generic graphics for modern windows for now, and deal with that in follow up bugs if we are able to get the glass color.
(Reporter)

Comment 6

7 years ago
Alex, I'm about to split Windows styling to 7/Vista (Aero Glass) and XP/Classic. The two questions I have are: Which styling will be using Aero Basic? Will be XP and Classic using the same style?
At the moment we can only style between default/classic until we get bug 543910 completed.
We can differentiate between Glass, Basic and Classic.
(Reporter)

Updated

7 years ago
Depends on: 590070
(Reporter)

Updated

7 years ago
Depends on: 590072
(Reporter)

Updated

7 years ago
Depends on: 590073
Depends on: 599348
Depends on: 599355
Depends on: 599342

Updated

7 years ago
Depends on: 595201

Updated

7 years ago
Assignee: nobody → margaret.leibovic
(Reporter)

Comment 9

7 years ago
Meta bug can have owner?

Comment 10

7 years ago
(In reply to comment #9)
> Meta bug can have owner?

I don't know, but I decided to take it since I own most of the bugs it's tracking, and I'll probably work on any new things that pop up related to this bug.
(In reply to comment #10)
> (In reply to comment #9)
> > Meta bug can have owner?

Should be shorlander.

Comment 12

7 years ago
I don't know it it should be reported here or under Bug 572482 ([Linux] UI Refresh) but current nigthly on Linux still don't have the anchor marker ("diamond" edge)which reduce the benefit of the change for doorhanger

Comment 13

7 years ago
(In reply to comment #12)
> I don't know it it should be reported here or under Bug 572482 ([Linux] UI
> Refresh) but current nigthly on Linux still don't have the anchor marker
> ("diamond" edge)which reduce the benefit of the change for doorhanger

Unfortunately there were some issues with implementing arrow panels for linux, so we're still waiting on that fix. See bug 604257.
(Reporter)

Comment 14

7 years ago
Margaret, I thought you were saying DH positioning will be fixed in this bugs. But Aero DH is misplaced.

Comment 15

7 years ago
(In reply to comment #14)
> Margaret, I thought you were saying DH positioning will be fixed in this bugs.
> But Aero DH is misplaced.

The patch for that hasn't landed yet. See bug 577928.
(Reporter)

Comment 16

7 years ago
Imposible, I have Aero Glass DH.
(Reporter)

Comment 17

7 years ago
DAMN! My bad, I mistaked it with styling *inside* DH.

Sorry, Margaret.

Updated

7 years ago
Depends on: 606343

Updated

7 years ago
Depends on: 610688

Updated

7 years ago
Assignee: margaret.leibovic → nobody

Updated

7 years ago
blocking2.0: betaN+ → ---
Keywords: meta

Updated

7 years ago
Depends on: 619422

Updated

7 years ago
No longer depends on: 590073
Whiteboard: [doorhanger]

Updated

7 years ago
Depends on: 630210
(Reporter)

Updated

7 years ago
Depends on: 645686

Updated

5 years ago
Blocks: 767321
This bug isn't clearly scoped and the referenced mockup is very much outdated.
No longer blocks: 588240, 767321
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.