keywords matching is no longer case insensitive

RESOLVED FIXED in mozilla2.0b5

Status

()

Toolkit
Places
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Radek 'sysKin' Czyz, Assigned: mak)

Tracking

({regression})

unspecified
mozilla2.0b5
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100823 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100823 Minefield/4.0b5pre

If you attempt to use bookmarks keyword, and you use an uppercase letter, it won't work

Reproducible: Always

Steps to Reproduce:
1. Make a keyword "g" or "G" for a bookmark
2. Enter "G" in urlbar

Actual Results:  
keyword doesn't work


Expected Results:  
you go to bookmarked page :)


See bug 572030 comment 30 for possible reason.\
(Reporter)

Updated

7 years ago
asking blocking for broken functionality
Assignee: nobody → mak77
Status: UNCONFIRMED → ASSIGNED
blocking2.0: --- → ?
Ever confirmed: true
Flags: in-testsuite?
Blocks: 572030
Keywords: regression
Summary: uppercase keywords are broken → keywords are no more case insensitive
(Reporter)

Comment 2

7 years ago
"no longer case insensitive" is not exactly right - if you make an uppercase keyword, you can still only access by typing it in lowercase.

So it's as if keywords were stored after converting to lowercase, but then matching happens to what was directly typed.
Summary: keywords are no more case insensitive → keywords matching is no more case insensitive
right, the problem is with the comparator that looks for the requested keyword than the lowercased keyword
Summary: keywords matching is no more case insensitive → keywords matching is no longer case insensitive

Updated

7 years ago
blocking2.0: ? → final+
Created attachment 469438 [details] [diff] [review]
patch v1.0
Attachment #469438 - Flags: review?(dietrich)
Attachment #469438 - Flags: review?(dietrich) → review+
Created attachment 469882 [details] [diff] [review]
patch v1.1

ready to qimport
Attachment #469438 - Attachment is obsolete: true
Hmm, ToLowerCase does Unicode aware lowercasing.  Is that necessary here?
are you arguing about perf? keywords are nsString and can contain anything
This was marked as ride-along but doesn't apply on m-c.

Comment 9

7 years ago
I'd really expect people to set non-ASCII keywords in language that have non-ASCII characters in usual language - e.g. even i German, I'd expect people to use äöü in keywords and expect then to work when using ÄÖÜ in the location bar to call them up.
https://hg.mozilla.org/mozilla-central/rev/2187c8bb6ff2
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b5

Updated

7 years ago
Duplicate of this bug: 591607
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.