If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[regression] Bookmark keywords are now case-sensitive, were and should be case-insensitive

VERIFIED DUPLICATE of bug 590081

Status

()

Toolkit
Places
VERIFIED DUPLICATE of bug 590081
7 years ago
7 years ago

People

(Reporter: BenB, Unassigned)

Tracking

({regression})

Trunk
Other
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Reproduction:
1. Create a bookmark for https://bugzilla.mozilla.org/show_bug.cgi?id=%s
2. In Bookmarks Manager, click on the bookmark, on "More", and enter
   in field Keyword: "bug"
3. In urlbar, enter "bug 100000"
4. In urlbar, enter "Bug 100000"

Actual result (in current trunk):
Step 3 goes to <https://bugzilla.mozilla.org/show_bug.cgi?id=100000>
Step 4 gives an "Alert" dialog with message
  "The URL is not valid and cannot be loaded."

Expected result (and IIRC in older builds):
Step 3 and 4 match: both go to
<https://bugzilla.mozilla.org/show_bug.cgi?id=100000>.
(Reporter)

Comment 1

7 years ago
Note: You need to also set keyword.enabled = false to get the error dialog. With the default of true, "Bug 100000" does a Google search. Which is still not the expected result.

Confirmed as regression. It was still working (get Expected result) with a build from 2010-07-08. I don't have builds in-between, would have to narrow down further.
Keywords: regression
(Reporter)

Updated

7 years ago
Summary: [regression] Bookmark keywords are now case-sensitive → [regression] Bookmark keywords are now case-sensitive, were and should be case-insensitive

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590081
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.