Closed Bug 590356 Opened 10 years ago Closed 10 years ago

Using Library makes the browser unusable

Categories

(Toolkit :: Places, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 491746
Tracking Status
blocking2.0 --- -

People

(Reporter: jrmuizel, Unassigned)

Details

I have a 64MB places database. If I search for something in the history search my browser will use full cpu and do a tremendous amount of IO. The browser will beachball for maybe 30s and then become usable until any navigation to a new page.

Ehsan was able to reproduce this but not to the extent that I was seeing.
blocking2.0: --- → ?
unless this is a regression from previous version, I doubt we could block on it, mostly because fixing it would require a quite deep rewrite.
Not a regression so I guess we keep this awful experience
blocking2.0: ? → -
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491746
You need to log in before you can comment on or make changes to this bug.