hitting enter in dialog boxes can cause crash

VERIFIED WORKSFORME

Status

P1
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: samuel, Assigned: mcafee)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Randomly, if you hit enter in dialog boxes instead of clicking ok, the browser
segfaults.  If it happens from clicking as well, it is much less often.

I finally managed to get a talkback build and caused it to crash.
The incident ID is: TB20347901Z
(Reporter)

Comment 1

18 years ago
ok, did it a couple more times now.
It seems to be almost guaranteed in the file browser for selecting a viewer for
an attachment that if you type in the application name and hit enter, it will
crash.  I tried several times with typing the name and then clicking ok and it
worked fine.  But as soon as I hit enter instead of clicking, it instantly crashed.

Talkback ID: TB20349502K in the file selector and another: TB20349577Q

Actually, it isn't instant.  The dialog goes away leaving a blank area, pauses
for a moment and I get this sinking feeling as I know in a couple of seconds all
my mozilla windows will go away...

Comment 2

18 years ago
I saw that too on my linux builds.

asa: could you retrieve the talkbacks please? ;)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
unfortuantely the talkback builds for linux seem to have broken talkback
functionality recently.  Over to XPApps/  
Assignee: asa → ben
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh
so, this is occurring the helper app save-or-open dialog?
Keywords: crash
QA Contact: sairuh → shrir
(Reporter)

Comment 5

18 years ago
It happens in ALL dialog boxes.
e.g. Chatzilla asks for a nick to use, you hit enter, Mozilla crashes.

Comment 6

18 years ago
This has been occurring for a long time on Linux builds.  I'm glad someone
finally identified what was causing the crash.
It's not likely that this is my bug (but you never know).

However, I won't be able to get this to the right person without a useful stack.

Comment 8

18 years ago
After upgrading from Mandrake 7.1 to 7.2, the bug has vanished.  Sorry, I guess
I won't be able to provide a stack trace.
(Reporter)

Comment 9

18 years ago
It seems to have gotten a little harder to reproduce, but here are 2 talkbacks:
TB21246523G  from chatzilla nick dialog
TB21248110Q  from form submit dialog
the last two stack traces are the same, here's one of 'em:

Incident ID 21246523 
 Trigger Time                2000-11-17 09:49:20 
 Email Address                samuel@sieb.net 
 User Comments                hit enter in chatzilla dialog box asking for nick 
 Build ID                2000111708 
 Product ID                Netscape6 
 Platform ID                LinuxIntel 
 Stack Trace

libgdk-1.2.so.0 + 0x241c2 (0x407651c2) 
libgdk-1.2.so.0 + 0x1448d (0x4075548d) 
libgdk-1.2.so.0 + 0x143eb (0x407553eb) 
libwidget_gtk.so + 0x14e5f (0x4088ee5f) 
libwidget_gtk.so + 0x151d9 (0x4088f1d9) 
libwidget_gtk.so + 0x150aa (0x4088f0aa) 
libgdk-1.2.so.0 + 0x15b80 (0x40756b80) 
libglib-1.2.so.0 + 0x10736 (0x40782736) 
libglib-1.2.so.0 + 0x10d43 (0x40782d43) 
libglib-1.2.so.0 + 0x10eec (0x40782eec) 
libgtk-1.2.so.0 + 0x785d9 (0x406d85d9) 
libwidget_gtk.so + 0xd2fc (0x408872fc) 
libnsappshell.so + 0xcc0a (0x40cf4c0a) 
mozilla-bin + 0x6275 (0x0804e275) 
mozilla-bin + 0x6845 (0x0804e845) 
libc.so.6 + 0x18cae (0x4026fcae)
nav triage team: crasher means beta stopper. 
Assignee: ben → mcafee
Keywords: nsbeta1
Priority: P3 → P1
(Reporter)

Comment 12

18 years ago
I haven't had this happen to me for quite a while now, since applying the
solution for bug 59345, which was upgrading the glib/gtk libraries.
Could someone who is still having this problem please try the solution listed in
bug 59345 and report back.

Comment 13

18 years ago
well, I can't reproduce this 'crash'on the helper app dialog. Tossing this back 
to sairuh to check on dialogs in her area.
QA Contact: shrir → sairuh
i haven't seen this [recently], so marking wfm per reporter.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.