Closed Bug 590543 Opened 10 years ago Closed 10 years ago

customization should support multiple toolboxes

Categories

(Toolkit :: Toolbars and Toolbar Customization, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 595937

People

(Reporter: dietrich, Unassigned)

References

Details

for the add-on bar, we want to have it be added to the pool of things that are customizable, and provide a single customization experience to the user.

in other words, when the user is in customize mode, they should be able to customize things outside of the navigation toolbox.
Blocks: 574688
Component: Toolbars → Toolbars and Toolbar Customization
Product: Firefox → Toolkit
QA Contact: toolbars → toolbars
Yesss!
From Alta88 on DAF:

"
TotalToolbar
http://totaltoolbar.mozdev.org/

to accomplish Bug 590543, with the highest amount of reuse of existing
customization arch, you will need to use the same methods as the
extension.  if the addon toolbar is a true toolbar (<toolbar> within
<toolbox>), 80% of the work will be done by merely passing gToolbox as
an array of toolboxes anywhere in the DOM rather than just the navigator
toolbox, and having an outer loop on the toolboxes. "
No longer blocks: 574688
Depends on: 595937
Bug 595937 covered the only use case I could think of.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 595937
You need to log in before you can comment on or make changes to this bug.