Last Comment Bug 595937 - Need support for customizing toolbars which are outside of the toolbox
: Need support for customizing toolbars which are outside of the toolbox
Status: RESOLVED FIXED
: dev-doc-complete
Product: Toolkit
Classification: Components
Component: Toolbars and Toolbar Customization (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla2.0b7
Assigned To: Mano (::mano, needinfo? for any questions; not reading general bugmail)
:
Mentors:
: 579506 590543 (view as bug list)
Depends on: 612588 652842
Blocks: 574688 590543
  Show dependency treegraph
 
Reported: 2010-09-13 11:39 PDT by Mano (::mano, needinfo? for any questions; not reading general bugmail)
Modified: 2011-04-26 21:57 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta7+


Attachments
patch (7.00 KB, patch)
2010-09-13 11:39 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
enndeakin: review+
Details | Diff | Review
for immediate checkin.... (1.19 KB, patch)
2010-09-13 17:55 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
no flags Details | Diff | Review

Description Mano (::mano, needinfo? for any questions; not reading general bugmail) 2010-09-13 11:39:57 PDT
Created attachment 474756 [details] [diff] [review]
patch

For the addon bar (see bug 574688) we need support for customizing toolbars which are outside of the DOM toolbox. An "external toolbar" would be a toolbar that its parent is *not* a toolbox, and on which a "toolboxid" attribute is set.
Comment 1 Dietrich Ayala (:dietrich) 2010-09-13 12:03:25 PDT
blocks landing of status bar removal, so blocks beta 6.
Comment 2 Neil Deakin 2010-09-13 12:57:13 PDT
Comment on attachment 474756 [details] [diff] [review]
patch

> function unwrapToolbarItems()
> {
>-  var paletteItems = gToolbox.getElementsByTagName("toolbarpaletteitem");
>-  var paletteItem;

You want to leave the declaration of paletteItem in.
Comment 3 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2010-09-13 13:20:34 PDT
Comment on attachment 474756 [details] [diff] [review]
patch

This is needed for the new addon-bar.
Comment 4 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2010-09-13 13:36:06 PDT
Comment on attachment 474756 [details] [diff] [review]
patch

I haven't noticed that beta6+ was set.
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2010-09-13 15:15:25 PDT
http://hg.mozilla.org/mozilla-central/rev/17d4ccd186bd
Comment 6 alta88 2010-09-13 17:29:03 PDT
in removeToolboxListeners()it should be removeEventListener..
Comment 7 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2010-09-13 17:55:01 PDT
Created attachment 474937 [details] [diff] [review]
for immediate checkin....

Thanks!
Comment 8 Dão Gottwald [:dao] 2010-09-14 01:52:38 PDT
*** Bug 590543 has been marked as a duplicate of this bug. ***
Comment 9 Dietrich Ayala (:dietrich) 2010-09-14 06:22:36 PDT
pushed the followup: http://hg.mozilla.org/mozilla-central/rev/e523182f9639
Comment 10 Dietrich Ayala (:dietrich) 2010-09-21 05:52:51 PDT
*** Bug 579506 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.