Closed Bug 59059 Opened 20 years ago Closed 18 years ago

With Quicktime extension disabled, Mac Mozilla will not launch

Categories

(SeaMonkey :: Build Config, defect, P3)

PowerPC
Mac System 9.x
defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: chrispetersen, Assigned: mikepinkerton)

References

Details

(Keywords: helpwanted, platform-parity, relnote, Whiteboard: relnote-user (culprint ?= InterfacesStubs))

Build: 2000110308
Platform: Mac
Expected results: The application should launch
What I get: The dialog appears " The application 'Netscape 6' could not be opened 
because 'QuicktimeLib' could not be found."
I didn't realize that N6 requires QT to run. Though, Mac Nav 4.7 and IE 5 will  
launch  if QT is disabled. This requirement needs to be in the release notes.

Step to reproduce:

1) In the Extensions manager, disable QT PowerPlug. Restart Mac.

2) Launch N6. Dialog appears.
Summary: With Quicktime extension disabled, N6 will not launch → With Quicktime extension disabled, Mac N6 will not launch
Verbage to be used in Release Notes:


Mac only: With Quicktime extension disabled, Netscape 6 will not launch
Keywords: pp, relnoteRTM
cc: pinkerton and smfr, mac experts by day.  Any ideas about this or who should
own this?

thanks!
Keywords: 4xp
Hey, so we're supposed to use the os where possible, I never considered this 
state [I guess it sucks].  Any thoughts?

Does that error basically mean that we linked against a library that the os 
could not load for us? In which case would we need to soften the link?
Timeless: Yes. weak-link in QuickTimeLib, and make sure that it doesn't try to 
actually use any of the QuickTime API unless QuickTime is loaded. If it's 
determined that Mozilla *really must have* QT, then weak-link it, check for its 
presence, and display an informative error message.
Whiteboard: relnote-user
We should put up an approprate warning here. Pink and I were just talking about 
this; we need to come up with a linkage scheme that works for Carbon too.
Assignee: asa → pinkerton
Component: Browser-General → Build Config
hrm, where did this sneak in? GFX is doing the right thing, I thought. Who else 
links against QuicktimeLib? I guess I can own this, but I'm really not sure I'm 
the right person.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9
widget links with QuickTime, for nsSound
The InterfacesStubs library also links against QuicktimeLib, non-weakly. This 

could be the main culprit, as could widget.

Target Milestone: mozilla0.9 → mozilla0.9.1
What do we do if OT is disabled also?
*** Bug 69235 has been marked as a duplicate of this bug. ***
FWIW, widget does not link against Quicktime.

if quicktime is part of carbonLib on X, then we need a way to figure out how to 
weak-link parts of carbonLib. can we just pull QT out of interfacesStubs and weak 
link against it where needed? will that screw up fizzilla's startup? shouldn't i 
guess because it's a weak link but...
after talking to simon, we dont think this will make or break user experience in 
the short term. futuring.
Target Milestone: mozilla0.9.1 → Future
Blocks: 91390
Blocks: 89720
I think this bug should be nominated for mozilla1.0. It's a serious issue 
with the Mac version in my opinion, and if it's not fixed for 1.0, I doubt it will 
ever be fixed.
What does this have to do with Mozilla?
extensions are optional, apps are supposed to play nice with optional things. At
the very least as noted above we should provide a friendly error message (note
that we can't really do this w/o solving the core problem but...).

i almost have a mac build env set up so i might look into this, i love lost causes.
Summary: With Quicktime extension disabled, Mac N6 will not launch → With Quicktime extension disabled, Mac Mozilla will not launch
Whiteboard: relnote-user → relnote-user (culprint ?= InterfacesStubs)
i agree with the above. does not look nice from mac users point of view to read
requires this and that extension. in the good old days ext like qt where
definately optional and maybe its ok for new mac user generation with osx and
g4s to think otherwise but one should not include such dependancies on 9.x
version. people responsible for the mac version should have thought these things
over or at least explicitly stated their intent (or their belief that old
mac-enthusiast dinosaurs like me should just die off) ...
OK, I vote for the old dinosaurs die-off!! %-P  Just kidding.. however, I think
we can take a vote and will find that the majority will agree that Quicktime is
a safe assumption since OS 9.. However, we're on OS 10 now for the most part and
most development now focuses on OS 10, so debating pre-9 conditions I think is
an exercise in futility at this point.. and honestly pretty pointless..

I do however think that it's absurd to require the Quicktime plug-in to view
non-QT content pages..  I think this should be put on the target milestone for a
fix soon so that legacy users won't beotch about having to install Quicktime.
Why they should complain about installing Quicktime is beyond me (unless the
version of Quicktime required to run Mozilla doesn't install on legacy
machines)...  If that's the case, speak up.  I think however that Quicktime 4 or
5 will install on every kind of machine back to 68030s..  and I wouldn't worry
about support for Mac Classics or 512 K machines with black and white screens..
We have to draw the line somewhere on hardware standards hindering software
development.  
Mozilla CFM build is dead.
http://groups.google.com/groups?threadm=avkj4k%24ihs2%40ripley.netscape.com
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.