Installation error -2804 when trying to install Mac Mozilla

VERIFIED FIXED in mozilla1.0

Status

--
blocker
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: kaldari, Assigned: slogan)

Tracking

({platform-parity})

Trunk
mozilla1.0
PowerPC
Mac System 8.6
platform-parity
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT3])

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

18 years ago
I haven't been able to install the latest Mac Mozilla build (7-5-01) due to 
installation error -2804 happening every time I try to install it. I'm running a 
pretty old OS - 8.6, and I only have 100 megs free on my hard drive, but I 
still fit within the system requirements. I've tried both the default 
installation and just installing the browser, but I still get the error 
regardless.

Updated

18 years ago
QA Contact: gemal → gbush

Comment 1

18 years ago
*** Bug 90160 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
looks like bug 90197 but different error number
It may be the same, but I doubt it given the different error number. Bug 90197 
affected everyone, we've only gotten a couple of reports of this error number.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

18 years ago
This bug seems to occur after downloading is complete and actual 
installation begins, unlike Bug 90160 which occurs while downloading 
the installer packages.
(Reporter)

Comment 5

18 years ago
Whoops, I meant Bug 90197, not Bug 90160. Sorry.
(Reporter)

Comment 6

18 years ago
After an incredibly tedious series of trial and error experiments, I've 
determined that this error is caused (for me at least) by not having the 
QuickTime PowerPlug Extension installed. QuickTime, BTW, is not listed 
as a system requirement for Mozilla. The error seems to occur 
immediately after the installer packages are extracted, but before they 
begin to actually install.
(Reporter)

Updated

18 years ago
Severity: normal → blocker

Comment 7

18 years ago
bingo!
I tried this as well. I actually had an expired beta version of QT on the 
machine. After removing that and installing the latest QT player, it installed 
smoothly!
CC'ing mac guys -- according to this bug, on OS 8.6 we require QuickTime or the 
install fails. I can't imagine the install wizard using QuickTime, so to me 
that means the product is using it (or something it installs). Have any 
developers tried running just the product without the installer on such a 
system?

Looking for any clues you could send our way.

(How common are systems w/out quicktime? This may be a blocker)
Keywords: nsBranch
I think it's getting it from zlib or libJar including interfacesStubs which 
strong-links against quicktime.

the app already requires quicktime to run (i have that bug), so it's probably 
acceptable that the installer requires it. We should release-note the requirement 
on quicktime and detect that it's not present when the installer starts up.
Is this something we can release-note? I don't think we can add UI to the 
installer at this point to tell users we didn't find QuickTime. At least not on 
the branch.

For the trunk, is the idea to remove this dependency in the future? Or should 
we plan on appropriate install changes for the trunk?
(Reporter)

Comment 11

18 years ago
If it's too late to add UI to the installer, would it be possible to just 
elaborate the error message? For example, could we have the installer 
spit out:

'Installation failed due to Error -2804 (QuickTimeLib not found)'

At least that would give users a clue as to why it failed and give them a 
chance to correct the problem and try the installation again.

BTW, is there any kind of public key as to what all these arcade error 
numbers really mean? It would probably be helpful if they were a little bit 
more descriptive.
(Reporter)

Comment 12

18 years ago
Freudian slip :)

arcade -> arcane
Errors in the -200 range or so are from nsInstall.h, plus one or two others 
that the install wizard itself supplies. These we could theoretically supply 
better text for.

Other random numbers are bubbling up from various failing parts of the app. 
We could catch these and say "Unexpected error" but we can't do much better 
than that until we debug each case. Better not to hide the number because these 
give us clues that one problem isn't the same as another (for example, see the 
attempt to dupe this bug against bugs 90160 and 90197 which had different error 
numbers and turn out to be quite different).

Comment 14

18 years ago
It might be OK to add the name QuickTimeLib to the text without getting in L10N
trouble, but the rest of the text would be a problem.  Since it's an error
message, it might be better to have the text non-localized than to have no text.
 Adding Michele to the CC list to make that call.

Seems like there needs to be a release note about QT being required on 8.6.  Has
that happened already?  (If not, please add a docs person to the CC list.

If this all gets worked out, please come to a pdt meeting or send email asking
for approval.
(Assignee)

Comment 15

18 years ago
The error handling and reporting needs work.
(Reporter)

Comment 16

18 years ago
According to bug 90160, this error affects Mac OS 9.x as well, so the 
release note should not be limited to Mac OS 8.6. I'm guessing the error 
will occur on any Mac OS without Quicktime enabled.

Concerning the error message, I think just adding 'QuickTimeLib' would 
certainly be better than nothing. Can we get that in place before the next 
branch?
(Assignee)

Updated

17 years ago
Keywords: relnote
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.4

Comment 17

17 years ago
SSU - Is this an issue? This hasn't been touched in quite a while?
(Reporter)

Comment 18

17 years ago
To fix this bug completely, bug 59059 has to be fixed. Unfortunately, that 
bug has been futured. The short term fix is to improve the error message, 
which as far as I know, has not been done. The bug has been release 
noted, but I think that's the only action that has been taken so far.
Depends on: 59059

Comment 19

17 years ago
Steve,

Can you add a blurb in the release notes (and/or the readme file as well) about
Quicktime requirement under Mac OS 8.6?
(Reporter)

Comment 20

17 years ago
As I wrote in my last post, this bug has already been release-noted. Also, 
this bug is NOT limited to MacOS 8.6 (as I've also written in a previous 
post).

Updated

17 years ago
Blocks: 99230

Updated

17 years ago
No longer blocks: 99230

Comment 21

17 years ago
Looks like we still can't "fix" this and we're stuck release noting it again in
this release.  If that's true, then please move it out of 094 and change it to
nsbranch-.

Updated

17 years ago
Keywords: nsbranch → nsbranch-
Target Milestone: mozilla0.9.4 → Future
(Reporter)

Comment 22

17 years ago
What about the short term fix of improving the error message? Wasn't 
Michele supposed to make a decision on this?

Comment 23

17 years ago
At this point it's too late to make UI changes. It's better to release note this. 
(Reporter)

Comment 24

17 years ago
What do you mean "at this point it's too late to make UI changes"? Too 
late for 0.9.5? Too late for 1.0? Too late forever? It's just changing 1 text 
string in the MacOS installer, right? That hardly seems to count as a user 
interface change. But then again, I'm only a lowly graphic designer, so 
what do I know :)

Comment 25

17 years ago
too late for netscape branch chnages. you can make changes to the mozilla release.
thanks

Updated

17 years ago
Keywords: nsbeta1
(Reporter)

Updated

17 years ago
Keywords: pp

Updated

17 years ago
Blocks: 104166

Updated

17 years ago
Keywords: nsbeta1

Comment 26

17 years ago
This is my first bug report, so if I'm doing sometime wrong be gentle...

I just got this bug tonight after downloading the most recent 0.9.5 for Mac.

The installer gave me the -2408 error immediately after the "expanding 
installation files" message.

I saw the Quicktime dependency in the correspondence below, and 
checked to find that I already had QT 4.1 installed.   Thinking maybe it was 
built against the latest version I downloaded and installed 5.0.2 and 
installed that (losing my "QT Pro" privileges in the process -- thanks, 
Apple!).  On trying the install again, I got the same error.

For comparison's sake I'm running OS 8.6 on a 9600 with an XLR8 
400mhz CPU upgrade.

Let me know if I can provide any more info.

John Neilson

Comment 27

17 years ago
Hrm, maybe we have a dependency on a routine not present in Mac OS 8.6.
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-

Comment 28

17 years ago
Sean, should this be reassigned?

Comment 29

17 years ago
reassigning to David Price - new installer engineer.
Assignee: ssu → dprice

Comment 30

17 years ago
	I get the Error -2804 during installation. I have QuickTime 5.0.2 installed; 
its QuickTime™ PowerPlug file is in the active Extensions folder.
	I'm running OS 8.6 on an 8600/200 with 288 MB of RAM and over a gig of free 
disk space.

Comment 31

17 years ago
syd, dprice, what's the status on this ? We need to identify what causes this
error on 8.6 if not QuickTime.

syd, in comment #15, back in July, you wrote: "The error handling and reporting
needs work." What kind of timeline did you have in mind when you wrote this ? We
definitely need to have more verbose in our installer error messages. Even
Windows error messages look better at this point.
(Assignee)

Comment 32

17 years ago
assigning to me
Assignee: dprice → syd
Keywords: nsbeta1 → nsbeta1+
Target Milestone: Future → mozilla1.0
(Assignee)

Comment 33

17 years ago
Created attachment 72355 [details] [diff] [review]
patch to cover this error, and many others
(Assignee)

Comment 34

17 years ago
Created attachment 72356 [details]
what it now looks like 

The error is definitely that the xpi stub library requires QT due to
dependencies in one of the libs it links in. I grabbed the error description
text from the MacErrors.h CW file that looked relevant to the kind of problems
we would see in this case, and a few others, and those are what we will
display. If the error number does not match one in the table, we revert back to
the display of an error number.
and what happens if we want to localize the installer to german?
(Assignee)

Updated

17 years ago
Attachment #72355 - Attachment is obsolete: true
(Assignee)

Comment 36

17 years ago
obsoleted patch, need to figure out a more localizable way perhaps (these are
mac system errors, I suppose using English is not correct, too bad macOS 8/9
doesn't have a better way to get a message from an error number, how lame).
Most of the non-package translatable wizard UI goes in install.ini (there are
Mozilla and commercial versions). Windows is different, combining both the
package-related text and the generic UI text in the same config.ini file.

Comment 38

17 years ago
Can we have a unified diff please?
(Assignee)

Comment 39

17 years ago
Created attachment 72563 [details] [diff] [review]
localizable patch

localizable patch
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: patch
(Assignee)

Comment 40

17 years ago
Created attachment 72566 [details] [diff] [review]
unified diff
some comments:

- the Str255 param should be |ConstStr255Param|

- fix the tabs/spaces in

> else 
> pstrcat(pMessage, pErrNo);
> if ( msg[0] != 0 ) {
> pstrcat(pMessage, "\p : ");

- when reading in the error table, does

> gErrTable = (ErrTableEnt *) realloc( gErrTable, (gErrTableSize + 1) * sizeof(
ErrTableEnt ) );

actually realloc for _every single item_? that seems...suboptimal. 

Comment 42

17 years ago
+int
+LookupErrorMsg( short code, Str255 msg )

Why the int return value? It's treated like a boolean, so use a boolean. This
ain't the unix kernal. Also, the name of the 'msg' param should indicate that
it's an out param (e.g. 'outMsgPString').

+OSErr
+ReadSystemErrors(const char *cfg)

Alignement is out. Also, this code is very allocation-happy. As pink notes, it
reallocs for every key, and also does a NewPtr of outValue, which is then copied
into an entry in the table, and then Disposed. Also, there is no reason to use
NewPtr in this function; malloc() will do fine, and be faster.
(Assignee)

Updated

17 years ago
Attachment #72563 - Attachment is obsolete: true
(Assignee)

Updated

17 years ago
Attachment #72566 - Attachment is obsolete: true
(Assignee)

Comment 43

17 years ago
Created attachment 72744 [details] [diff] [review]
incorporates simon's suggestions, ran my code thru bbedit to remove tabs (files where I just added an argument to the function I left alone)
(Assignee)

Comment 44

17 years ago
Created attachment 72895 [details] [diff] [review]
use calloc in place of Mac Toolbox func, improve how we deal with failure
(Assignee)

Comment 45

17 years ago
Simon, reassign back to me when you have r= the bug, or have more changes you want.
Assignee: syd → sfraser
Status: ASSIGNED → NEW
(Assignee)

Comment 46

17 years ago
reassigning to me again
Assignee: sfraser → syd
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: relnote

Comment 47

17 years ago
Comment on attachment 72895 [details] [diff] [review]
use calloc in place of Mac Toolbox func, improve how we deal with failure

sr=sfraser
Attachment #72895 - Flags: superreview+

Comment 48

17 years ago
ADT3 per ADT/XPInstall triage.
Whiteboard: [ADT3]

Comment 49

17 years ago
Comment on attachment 72895 [details] [diff] [review]
use calloc in place of Mac Toolbox func, improve how we deal with failure

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #72895 - Flags: approval+
(Assignee)

Comment 50

17 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 51

17 years ago
Thanks guys. If you're ever in Nashville, drinks are on me :)
(Reporter)

Comment 52

17 years ago
When I try an installation without Quicktime installed now, I get the 
following error:

Installation failed due to error: The named library was not found.: 
QuickTimeLib

Yippie! Excellent work guys. At least now people will know how to prevent 
this error and will be able to get Mozilla installed without too much effort. 
Now if only we can get bug 59059 fixed by 1.0....

Comment 53

17 years ago
verified per reporters comments
Status: RESOLVED → VERIFIED

Comment 54

17 years ago
I'm removing this release note item for this bug from the Mozilla 1.0 and
future versions of the release notes because this bug is marked fixed.

Mail me if you think this item should be re-added.
(Assignee)

Updated

17 years ago
Keywords: fixed1.0.0

Comment 55

17 years ago
this was fixed and verified before the branch cut
no adt1.0.0, removing fixed1.0.0
Keywords: fixed1.0.0
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.