Multiple AwesomeScreen tabs are shown as selected when device is rotated to landscape

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Mozilla/5.0 (Android; Linux armv7l; rv:2.0b5pre) Gecko/20100827 Namoroka/4.0b5pre

Currently, when one selects 'Bookmarks' on the AwesomeScreen in portrait, 'Bookmarks' will appropriately be the selected and active tab. 

When you rotate to landscape, either 'All Pages' or 'History' will also be shown as selected (different grey tone)[1]. As or which one, I am getting mixed results, sometimes All Pages will be shown as selected and sometimes History.

[1] Bookmarks will still continue to be the active tab

STR:
1. Select 'Bookmarks' tab
2. Rotate device

AR: On landscape rotation, 'Bookmarks' tab alongside All Pages or sometimes 'History' is shown as selected. 

EX: On landscape rotation, 'Bookmarks' tab should be the single tab shown as selected.
(Reporter)

Comment 2

8 years ago
Created attachment 469867 [details]
Two selected panels

All Pages + Bookmarks are both selected - notice History/Desktop have a differently applied CSS class
(In reply to comment #2)
> Created attachment 469867 [details]
> Two selected panels
> 
> All Pages + Bookmarks are both selected - notice History/Desktop have a
> differently applied CSS class

This looks crazy. Is your top-left icon always the favicon or is it sometimes a mangifier?
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Created attachment 469867 [details] [details]
> > Two selected panels
> > 
> > All Pages + Bookmarks are both selected - notice History/Desktop have a
> > differently applied CSS class
> 
> This looks crazy. Is your top-left icon always the favicon or is it sometimes a
> mangifier?

Favicon
OS: Android → All
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > Created attachment 469867 [details] [details] [details]
> > > Two selected panels
> > > 
> > > All Pages + Bookmarks are both selected - notice History/Desktop have a
> > > differently applied CSS class
> > 
> > This looks crazy. Is your top-left icon always the favicon or is it sometimes a
> > mangifier?
> 
> Favicon

Maybe some of the changes have not been taken into the last nightly. We need to check that tomorrow.

Comment 6

8 years ago
i'm on the 0826 build, using a Nexus One, and was able to reproduce comment 0.

Comment 7

8 years ago
Created attachment 469942 [details]
Bookmarks History selected screenshot

Also got bookmarks and history to be highlighted.
Could you reproduce it with today's build?
(Reporter)

Comment 9

8 years ago
This seems fixed with 08/30. Which bug fixed this?
(In reply to comment #9)
> This seems fixed with 08/30. Which bug fixed this?

In my opinion this is bug 590317. I though some of the bugs I have landed at this time have not been taken into account in the nightly since the screenshoot you upload was having UI elements I've removed into bugs I've fixed this past day.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified FIXED on builds:
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100831 Namoroka/4.0b5pre Fennec/2.0a1pre

and

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100831 Namoroka/4.0b5pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.