Borders are rendered with gaps at the corners when different colors are specified for individual sides

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: note2chris, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b5pre) Gecko/20100827 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b5pre) Gecko/20100827 Minefield/4.0b5pre

When creating a box using CSS borders a gap is rendered at the corners of the box if different colors are specified for individual sides.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.w3schools.com/css/tryit.asp?filename=trycss_border-color
2. The css examples here should show the problem.
3. Try the same page in Firefox 3.6
Actual Results:  
Borders are rendered with a break at the corner

Expected Results:  
border corners should meet.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
Cannot repro on WinXP.
To test if this is an D2D Rendering Issue, check "about:support" very bottom "Direct2D Enabled" Status.
Test against setting "mozilla.widget.render-mode" to 0 using about:config.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
This only shows with Direct2D enabled.
(Reporter)

Comment 3

8 years ago
Created attachment 469903 [details]
An image that shows the gap.
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Looks like we lose the beveling on one end of the border there somehow.  Bas?
Blocks: 549116
blocking2.0: --- → ?
Keywords: regression
looks like a dupe of bug 590407
Related, but may not be dup; there are no rounded borders here.
Status: UNCONFIRMED → NEW
Depends on: 590407
Ever confirmed: true
Huh, I can't reproduce this. In the latest nightlies, we have more information about your video card in about:support - Chris, can you paste that here?
I can reproduce it.

        Adapter Description        NVIDIA GeForce 7050 / NVIDIA nForce 610i
        Vendor ID        10de
        Device ID        07e3
        Adapter RAM        256
        Adapter Drivers        nvd3dum
        Driver Version        8.17.12.5721
        Driver Date        6-7-2010
        Direct2D Enabled        true
        DirectWrite Enabled        true
Nvidia 7050 is D3D9.
(Reporter)

Comment 10

8 years ago
Adapter Description NVIDIA Quadro NVS 110M 
Vendor ID 10de
Device ID 01d7
Adapter RAM 128
Adapter Drivers nvd3dum nvwgf2um
Driver Version 7.15.11.7967
Driver Date 3-6-2009
Direct2D Enabled true
DirectWrite Enabled true
These are all DirectX 9 parts; we don't officially support those, so this issue can't block.
blocking2.0: ? → -
Do we need to blacklist them, then?
No. These users have turned on D2D explicitly; blacklisting is for where it causes more pain than just bad drawing.
Oh, I see.  So is the plan to default d2d off on unsupported hardware but allow users to override?
Right. ("Allowing" users to override really just means not disallowing them from overriding.)
I believe this is now fixed.
Depends on: 588271
Created attachment 494904 [details]
Connected D2D borders

This is working for me now with the landing of bug 588271, D2D Nvidia 7050.
Closable as WFM/Fixed by Bug 588271 then?
Sure.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.