Last Comment Bug 591661 - sync does not allow to use an own server
: sync does not allow to use an own server
Status: RESOLVED DUPLICATE of bug 602685
:
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Madhava Enros [:madhava]
:
Mentors:
: 603082 (view as bug list)
Depends on: 602685
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-28 12:17 PDT by alex
Modified: 2010-11-18 15:30 PST (History)
11 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description alex 2010-08-28 12:17:51 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: android alpha

i am using firefox sync (mozilla weave) with my own server on desktop, but the android fennec browser does not allow to enter the url for the own server.

Reproducible: Always

Steps to Reproduce:
-
Actual Results:  
-

Expected Results:  
-

-
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2010-08-28 21:21:35 PDT
We do not expose any UI, but you might be able to use about:config to set a custom server.

Madhava - Any thoughts on adding the UI for a custom server? I wonder how pervalent it is? Also, maybe the about:config method is good enough, especially for Fennec 2
Comment 2 alex 2010-08-29 13:54:22 PDT
oh, i will try it. if it works via about:config its okay for me, because i do not need to change this everyday :)
Comment 3 Aakash Desai [:aakashd] 2010-09-09 11:42:47 PDT
Did this work for you, Alexander?
Comment 4 alex 2010-09-09 12:26:25 PDT
no, i found no config keys for sync in about:config. cannot try at the moment, because fennec does not want to run at all. but i'm not sure if i am having the correct version now (or should every .apg work?)
Comment 5 Philipp von Weitershausen [:philikon] 2010-09-16 15:13:55 PDT
It's possible to do this with about:config, but it's a bit tricky. Every time you change the username and hit Connect, Sync preferences are reset. So the workflow is:

1. Enter your username (and some *fake* password and passphrase) and hit Connect, expect error.

2. Go to about:config and change services.sync.serverURL to your custom Sync server.

3. Go back to the Sync settings and enter your real password and passphrase. *Don't* change the username (otherwise services.sync.serverURL will be reset).
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2010-10-09 06:46:42 PDT
*** Bug 603082 has been marked as a duplicate of this bug. ***
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2010-10-13 13:56:49 PDT
Mike - thoughts on this?

Madhava - How would we expose this, if we want to do it?
Comment 8 Mike Connor [:mconnor] 2010-10-13 19:27:18 PDT
This was a big deal for FxHome, and is part of our overall "you don't have to use our service" story...
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2010-10-13 19:56:43 PDT
Let's figure out the UI issues. Also, what moving parts do we need to worry about? Is this as simple as exposing a textbox for the URL? (I doubt it)
Comment 10 Philipp von Weitershausen [:philikon] 2010-10-18 08:38:12 PDT
(In reply to comment #9)
> Let's figure out the UI issues. Also, what moving parts do we need to worry
> about? Is this as simple as exposing a textbox for the URL? (I doubt it)

It is as simple as exposing a textbox that corresponds to the services.sync.serverURL pref. You just need to be aware that Weave.Service.startOver() as used by the login code right now [1] resets all sync prefs, including serverURL. But that'd be easy to work around.

[1] http://mxr.mozilla.org/mobile-browser/source/chrome/content/sync.js#74
Comment 11 Doug Turner (:dougt) 2010-10-19 13:19:04 PDT
i think this is screaming "addon".
Comment 12 Philipp von Weitershausen [:philikon] 2010-10-19 14:54:39 PDT
(In reply to comment #11)
> i think this is screaming "addon".

Possibly, though the current code would make it harder than necessary for an add-on to provide this feature.
Comment 13 Mike Connor [:mconnor] 2010-10-19 15:00:18 PDT
I think Ragavan needs to make this call.  I know that there were a lot of negative responses to FxHome not exposing this, and I don't see a compelling reason why Fennec can't implement this.
Comment 14 Doug Turner (:dougt) 2010-10-19 15:15:48 PDT
I can understand your concern mconnor.

ragavan, this is a browser for smaller screen devices (not desktop 24" screens).  real estate is very important.  having another yet option that very few people use is just not an option for us.
Comment 15 Stuart Parmenter 2010-10-19 15:35:35 PDT
We'll need to figure out where it lives.  It shouldn't be in the primary prefs panel, and we don't currently have an advanced section.
Comment 16 Ragavan S [:rags] 2010-10-19 18:13:41 PDT
(In reply to comment #15)
> We'll need to figure out where it lives.  It shouldn't be in the primary prefs
> panel, and we don't currently have an advanced section.

What are our options if it is not in the primary prefs panel? Are there plans to have an advanced section for Firefox 4?

And to answer Doug's comment #14, I understand that this is for smaller screen devices, but being able to connect to your own custom server is an important part of our promise to users. I agree that it is not a common use case, but we shouldn't make it impossible to connect to personal servers.
Comment 17 Mark Finkle (:mfinkle) (use needinfo?) 2010-10-19 18:14:49 PDT
(In reply to comment #12)
> (In reply to comment #11)
> > i think this is screaming "addon".
> 
> Possibly, though the current code would make it harder than necessary for an
> add-on to provide this feature.

What kinds of things should we fix?
Comment 18 Matt Brubeck (:mbrubeck) 2010-10-19 18:16:53 PDT
If we don't want to add a new pref row for the server setting, then on the same row as the "Connect" button we could add a "More Options" or "Choose Server" button...
Comment 19 Philipp von Weitershausen [:philikon] 2010-10-20 02:04:13 PDT
(In reply to comment #17)
> (In reply to comment #12)
> > (In reply to comment #11)
> > > i think this is screaming "addon".
> > 
> > Possibly, though the current code would make it harder than necessary for an
> > add-on to provide this feature.
> 
> What kinds of things should we fix?

As mentioned in comment 10, the login code resets all prefs when the user logs in with a different account [1]. This is definitely the correct behaviour, but it will also wipe the services.sync.serverURL pref. My suggestion is that the login code would carry that one setting over, independent of whether the actual custom server textbox was provdied by an add-on or not. E.g.:

     // Cause the Sync system to reset internals if we seem to be switching accounts
     // but keep the custom server setting.
     let serverURL = Weave.Svc.Prefs.get("serverURL");
     if (this._settings.account.value != Weave.Service.account) {
       Weave.Service.startOver();
       Weave.Svc.Prefs.set("serverURL", serverURL);
     }

[1] http://mxr.mozilla.org/mobile-browser/source/chrome/content/sync.js#74
Comment 20 Mark Finkle (:mfinkle) (use needinfo?) 2010-10-26 13:38:34 PDT
Let's make a decision for final
Comment 21 Madhava Enros [:madhava] 2010-11-02 12:31:53 PDT
I may have missed this, but can we have a line in about:config that, by default, points to the mozilla server, but that a user can change to point to his or her own?

It seems to me that anyone who is interested in setting up his or her own server would be comfortable enough going into about:config to set this.

Is the concern that this is not sufficiently "surfaced" for our "you don't have to use Mozilla servers" story?
Comment 22 Mike Connor [:mconnor] 2010-11-02 13:40:42 PDT
a) It does exist already, it's just not especially good UX for those users.
b) The hope is that it gets as easy as installing WordPress, and it's already been suggested that some companies will/have set up their own servers internally so their users can use Sync without necessarily having to trust external providers.

All that said, this will only need to show up in the fallback UI in the setup flow, as the J-PAKE piece will carry over server settings if need be.
Comment 23 Philipp von Weitershausen [:philikon] 2010-11-02 14:11:25 PDT
Right, as mconnor mentions it already exists, but it's very clunky to actually use (even with about:config). My suggestion in comment 19 should make it better. I'll be happy to round that up into a patch if we decide not to surface this at all in UI.
Comment 24 Doug Turner (:dougt) 2010-11-02 14:50:32 PDT
I do not believe that changing a preference in about:config is any worse UX than what a developer (not user) has to do today to install a weave server.  Unless part b of comment 22 is fulfilled, we should not even consider adding this advanced feature to the Fennec UI.
Comment 25 Matt Brubeck (:mbrubeck) 2010-11-02 14:55:31 PDT
(In reply to comment #24)
> I do not believe that changing a preference in about:config is any worse UX
> than what a developer (not user) has to do today to install a weave server. 

This reasoning doesn't work in the case where one person sets up a server for others to use.  (Anecdotally, this is what we did with the Xmarks server when I worked at Amazon, so that people could sync bookmarks in a security-approved way.)
Comment 26 Doug Turner (:dougt) 2010-11-02 14:57:30 PDT
> This reasoning doesn't work in the case where one person sets up a server for
others to use.  (Anecdotally, this is what we did with the Xmarks server when I
worked at Amazon, so that people could sync bookmarks in a security-approved
way.)

If you are smart enough to setup a server, you are smart enough to distribute an addon.  It would probably be easier in that way then tell your user's to switch some preference.
Comment 27 Mike Connor [:mconnor] 2010-11-02 22:02:49 PDT
I don't understand why you're arguing about an extra toggle/text field which will only be displayed if the easy setup path fails for some reason.  Having to enter this separately is pretty crappy UX, but I think you're taking a fairly narrow view of possibilities.  From a Sync product POV, this is an essential part of the product offering, and a surprising number of users already make use of this option.

FWIW, b) is an expected outcome with the new Python-based server, which has a metapackage and a default config that gets you up and running very quickly.
Comment 28 Doug Turner (:dougt) 2010-11-02 22:15:19 PDT
as long as we don't use any addition space in the default case, i will be happy.
Comment 29 Doug Turner (:dougt) 2010-11-02 22:23:38 PDT
okay, that was too terse.  following the election and didn't give this enough:

i am mostly worried about preferences creep.  I think we already have too many options.  (Disable images?  we are in 2010, and writing a modern web browser.  the web doesn't work without images, and if you really want to do this, use an addon!)  I filed bugs to remove this and the disable js.

mike, how about instead of having all of this management of one's account in the preferences as it is, how about having a button in our prefs that takes you to about:sync and management in content?  You'll have a ton more room and flexibility.   Of course, I defer to madhava.  He makes miracles happen.  Maybe he can figure out the balance here.  I just hate to see more stuff (even important stuff like sync) clutter up the preferences list.  I hope you can understand.
Comment 30 Mike Connor [:mconnor] 2010-11-03 07:08:39 PDT
Let's back up: this shouldn't be a pref, just like entering account creds shouldn't be pref lines.  The current UI is changing, this isn't an "add a line to the current UI" bug at this point, IMO.

To establish context, there's a new-and-being-mocked-up setup flow which should prevent this from being shown in the 99% case (we'll securely pair and pass over user/pass/key/custom server (if set)), I'm just pointing out that the fallback with manual entry also should allow entry of a custom server, like our other two clients.
Comment 31 Mark Finkle (:mfinkle) (use needinfo?) 2010-11-03 07:35:16 PDT
Yes, the Sync UI in Fennec will be changing soon. I suspect we could start changing it now, to something like:
* Use preference UI to show status, connect/disconnect and open setup
* Use about:sync-setup in-content UI to show any and all setup related to Sync

For now, we could simply port the username/password/key UI to the about: page. Soon, we would be adding the new setup workflow to the about: page

(I suggest keeping the minimal preference UI since we would never give up any other, more primary UI space for this)
Comment 32 Madhava Enros [:madhava] 2010-11-03 13:38:25 PDT
Wait a minute.

Is this still an issue at all with the move to JPAKE as the only way of
connecting in Fennec?

If you you have to connect your device by going to a copy of Firefox already
paired with your account -- that account is already associated with the server
you intend to use, no?  So you wouldn't have to specify the server in Fennec -
it would be part of the account information, wouldn't it?
Comment 33 Madhava Enros [:madhava] 2010-11-03 14:05:50 PDT
Oh, mconnor answered my question in comment 30.  I should reload before commenting.
Comment 34 Brad Lassey [:blassey] (use needinfo?) 2010-11-04 13:01:52 PDT
we won't block shipping fennec 4.0 on supporting a private server for sync. Patches welcome and will probably get approval though.
Comment 35 Mark Finkle (:mfinkle) (use needinfo?) 2010-11-05 07:34:36 PDT
Sync UI rework will happen in bug 602685
Comment 36 Madhava Enros [:madhava] 2010-11-11 07:42:54 PST
Fennec connection UI for sync, accommodating using a custom server if you choose not to use pake.  If you _are_ using pake with a custom server (which I've been told will be the normal case), you just use the regular pake flow, given that you're connecting with an account that obviously knows what server it's associated with.

http://www.flickr.com/photos/madhava_work/5164827140/sizes/l/
Comment 37 Madhava Enros [:madhava] 2010-11-18 14:38:44 PST
What should we do with this bug?
Comment 38 Matt Brubeck (:mbrubeck) 2010-11-18 15:30:37 PST
This will be fixed when bug 602685 is complete; resolving as duplicate.

*** This bug has been marked as a duplicate of bug 602685 ***

Note You need to log in before you can comment on or make changes to this bug.