Harder to trigger PERMISSION_DENIED with new Geolocation UI

RESOLVED DUPLICATE of bug 675533

Status

()

defect
RESOLVED DUPLICATE of bug 675533
9 years ago
4 years ago

People

(Reporter: robertc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b5pre) Gecko/20100828 Firefox/4.0b5pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b5pre) Gecko/20100828 Firefox/4.0b5pre

In Firefox 3.6 if you call getCurrentPosition from code the user is presented with an option to allow or deny, and a tick box to remember the choice.  Clicking on deny fires the error callback with the PERMISSION_DENIED error code.

In the current 4.0 nightly there's a popup from the location bar with a single option 'Share Location'.  There's no option to deny, and there's no option to remember the decision.

While this new interface is simpler for the user thanks to the total lack of options, it's going to be confusing for developers because it seems to make the case where getCurrentPosition never completes more common.  It would be nice if some sort of callback was returned if the user clicks outside the confirmation so the code can choose to stop or continue waiting.

It'll also be annoying for users making use of geo enabled sites having to click the button on every page load.

At a minimum the change should be noted in the Firefox 4 for developers page and the example code on the Geolocation documentation should be updated with a sensible way of dealing with this.

Reproducible: Always
Component: Location Bar → Geolocation
Product: Firefox → Core
QA Contact: location.bar → geolocation
This problem was already mentioned in bug 398776. Though maybe this should be blocking that bug? Also note bug 615318, maybe it can be used to fix this. A URL to test this is of course http://maps.google.com
Duplicate of this bug: 635175
Popups now contain "Never share" options which trigger PERMISION_DENIED, so the bug title needs some updating.  You specifically have to look for the option, though, and it's permanent, so it's not equivalent to 3.6.
Summary: Impossible to trigger PERMISSION_DENIED with new Geolocation UI → Harder to trigger PERMISSION_DENIED with new Geolocation UI

Updated

8 years ago
Duplicate of this bug: 650247

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

4 years ago
Some of this bug has been addressed, what's remaining is the same as what's tracked in bug #675533.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675533
You need to log in before you can comment on or make changes to this bug.