Firefox 4 does not call the geolocation error callback when "not now" is clicked

RESOLVED DUPLICATE of bug 591745

Status

()

defect
RESOLVED DUPLICATE of bug 591745
9 years ago
8 years ago

People

(Reporter: galenjr, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

Firefox 4 does not call the geolocation error callback when "not now" is clicked

Reproducible: Always

Steps to Reproduce:
1. Load a site that has geolocation (http://jsfiddle.net/aUh6x/)
2. When prompted for access to geolocation click not now
Actual Results:  
Geolocation error callback is not called

Expected Results:  
Geolocation error callback should be called. In the above link an alert box should pop up. If you click 'never' instead of 'not now', the error callback is fired.
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110415 Firefox/6.0a1 ID:20110415030523, but unsure if this isn't by Design.
Version: unspecified → Trunk
previous versions of firefox called the error callback when "not now" was chosen. How else would the page know geolocation is unavailable?
Confirming issue on Mozilla/5.0 (X11; Linux i686; rv:5.0a2) Gecko/20110418 Firefox/5.0a2

Regression range (ever since the 'Not now' option was introduced)

Last good:
Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101216 Firefox/4.0b9pre
http://hg.mozilla.org/mozilla-central/rev/a5413c3c1013

First bad:
Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101217 Firefox/4.0b9pre
http://hg.mozilla.org/mozilla-central/rev/d1da1005b6d6

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a5413c3c1013&tochange=d1da1005b6d6
Status: UNCONFIRMED → NEW
Ever confirmed: true
This behavior was intentional because the "Not Now" option is supposed to do the same thing as clicking outside the popup to dismiss it. This dismissal does not completely remove the notification, since you can still click on the icon to make a choice, so it wouldn't make sense to call the error callback.
I'm going to mark this as a dupe of bug 591745, since that bug describes the fundamental problem. The "Not Now" option was just added later as a UX work-around for users who couldn't figure out how to click outside the popup. It's present in all notification popups, and it does the same thing in all of them.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591745
You need to log in before you can comment on or make changes to this bug.