Hibernate tab groups in Panorama

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
8 years ago
a year ago

People

(Reporter: j6cubic+mozilla, Unassigned)

Tracking

(Depends on: 2 bugs)

Dependency tree / graph

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

I'm currently stuck on 4.0b1 as I'm a heavy user of tab groups and the extension I use is incompatible with the new XPCOM. Panorama could replace this extension except for the fact that unlike Panorama the extension allows me to hibernate groups – the tabs are unloaded from memory and the extension saves their URIs to disk.

It would be great if Panorama could hibernate and restore tab groups; this would allow heavy users of tab groups to separate currently-used groups from groups kept for future reference (as well as keeping currently-unused tabs out of memory).

Reproducible: Always




The extension I use is TabGroups Manager (https://addons.mozilla.org/de/firefox/addon/10254/).

Updated

8 years ago
Summary: Hibernate tab groups in Panorama → Hibernate tab groups in Panorama (ability to not load hidden tabs at all)
Version: unspecified → Trunk
We've passed feature freeze; punting this to post-ff4.

Note that this would probably build on on the work started in bug 595601.
Depends on: 595601
Target Milestone: --- → Future

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Duplicate of this bug: 645140
Assignee: nobody → tim.taubert
Status: NEW → ASSIGNED
Depends on: 675539
Summary: Hibernate tab groups in Panorama (ability to not load hidden tabs at all) → Hibernate tab groups in Panorama
Target Milestone: Future → ---
I'm not going to work on this.
Assignee: ttaubert → nobody
Status: ASSIGNED → NEW

Updated

5 years ago
Depends on: 865594

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.