"fr-fr,en-us=0.7" should match fr, not en-US

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
When you click on "Modules", you are redirected to the english support page for the features add-ons :
https://addons.mozilla.org/en-US/firefox/?browse=featured
instead of :
https://addons.mozilla.org/fr/firefox/?browse=featured
Works for me, it will redirect to the firefox addons home page which does locale detection so if you visited the previous French page with an  English speaking browser you get the en-US version of the addons site, hardcoding urls is not really wanted for AMO since we have less locales supported there than on mozilla-europe.org .
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

8 years ago
In Firefox 3.6, it works.
In Firefox 4.0 beta, there is no more localization in the UA string for confidentiality reasons, that is why it does not work.

I use an english Minefied, and mozilla-europe.org is in french except for the Module link
So Module link must be set according to the site language and not to the browser language.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
We don't use UA but accept-lang headers for locale detection, it works in Trunk builds and we send pages according to the visitors preferences "choose your prefered language for displaying page". If you want pages displayed in French but use an English Minefield, you should put that in your preferences. You should probably use a French minefield though. I am marking that as WFM again since this is the intended behaviour for the general public, I am happy to discuss that with you in our #frenchmoz channel on IRC (irc.mozilla.org) though, my nick is pascalc.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Summary: [fr] "Modules" refers to the english support page → [fr] "Modules" refers to the english addons page
(Reporter)

Comment 4

8 years ago
Additional information :
My preferred language in my english Minefield is set to fr-fr.
The automatic language redirection of mozilla-europe.org is done according to the preferred language. This feature is fine

Correction in comment 2 :
replace mozilla-europe.org by mozilla-europe.org/fr
if your preferred language is fr-fr and you are redirected to https://addons.mozilla.org/en-US/firefox version when going to https://addons.mozilla.org/firefox, then it is more likely a bug in the locale detection code on addons.mozilla.org, reopening and moving the bug to that component.
Assignee: pascalc → nobody
Status: RESOLVED → REOPENED
Component: www.mozilla-europe.org → Localization
Product: Websites → addons.mozilla.org
QA Contact: www-mozilla-europe-org → l10n
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

8 years ago
When going to :
1.  https://addons.mozilla.org/firefox, I am redirected to https://addons.mozilla.org/fr/firefox/?browse=featured
2.  https://addons.mozilla.org, I am redirected to https://addons.mozilla.org/en-US/firefox/?browse=featured

"Modules" link in mozilla-org/fr use 2.
Can you paste your request headers (or at least the Accept-Language string)?
(Reporter)

Comment 8

8 years ago
Preferred Language string :
* For FF 3.6 fr:       Français [fr]   or   Français/France [fr-fr]
* For FF 4.0b4 en-US : French/France [fr-fr]

Summary of comment 2 and comment 6 about https://addons.mozilla.org redirection :
* OK with FF 3.6 fr
* NOK with FF 4.0b4 en-US
Could you please attach/paste the output from http://www.ioerror.us/ip/headers?
(Reporter)

Comment 10

8 years ago
GET /ip/headers HTTP/1.1
Host: www.ioerror.us
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100830 Firefox/4.0b5pre
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: fr-fr,en-us;q=0.7,en;q=0.3
Accept-Encoding: gzip, deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Connection: keep-alive
Thanks for the headers! cc'ing Fred since he's been talking about this in bug 582075.
Status: REOPENED → NEW
Summary: [fr] "Modules" refers to the english addons page → "fr-fr,en-us=0.7" should match fr, not en-US
/me nods -- yup, that's the same bug in two different apps.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.