Display containing folder for messages in search results for "search all messages"

RESOLVED DUPLICATE of bug 570787

Status

Thunderbird
Search
--
enhancement
RESOLVED DUPLICATE of bug 570787
7 years ago
7 years ago

People

(Reporter: realgrouchy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 

The new "Search all messages" feature is very nice; however, I am looking for an e-mail that I mistakenly filed in the wrong folder.

The search results display list of folders that contain messages matching the search parameters, and it also displays a list of all those messages. I see the correct message, but there is no way to determine which folder it is in: the containing folder isn't listed in the list, there's no (obvious) context menu option to look at the containing folder, and I can't figure it out from clicking the message and opening it. Going the other way, I'd have to go through each folder containing matching messages to see if I can find the particular message in that folder.

It would be nice if this information was easier to get at, such as:
- display the folder name for each message in the search result summary
- add an option to open/view the containing folder (which is requested in comment 1 on Bug 509422)
- as you hover over the subject line for each message in the results, the folder name of the containing folder on the left also highlights (and vice versa)

I also note that if I select "from me" for this particular search, all of the results must be in the same folder, because the folder name disappears on the left. 

Once I found the subject line of the message I wanted in this view, I was able to go into the traditional "search all messages" search to look for the message by that subject line, but I shouldn't have to search twice for a message I've already found!

- RG>

Reproducible: Always
So what's different in this bug than in bug 509422 ? This also looks like a dup of bug 570787 , don't you thing ?
(Reporter)

Comment 2

7 years ago
Thanks for asking before marking it as s duplicate. My response to your question is below.

However, I did find a roundabout way to get the information I was looking for. I wasn't aware of the "view as list" search results option, from which I was able to add the "location" column to the results to see where my message is. Still it would be easier to right-click on a message in the default results view to find the folder.


Bug 509422 has a comment (Comment 1) that asks for similar features to what I'm requesting, but that comment does not reflect the original bug reported in 509422. The original bug (the title of which is just generic 'enhancements', which is non-specific and difficult to track) requests the ability to open the results in message list view. The comment asks for better folder results, which could be construed under the bug's heading of "enhancements", but really the bug should have a more specific focus.

Bug 522768 is a similar request, but for the "Search Messages" (Ctrl+shift+F) feature, not the "Search All Messages" toolbar search (Ctrl+K). The two have very different interfaces and results panes.

It is unclear which search interface 570787 refers to, so I have reported this bug specifically for the "Search All Messages" feature.
(In reply to comment #2)
 
> It is unclear which search interface 570787 refers to, so I have reported this
> bug specifically for the "Search All Messages" feature.

The new search, just like your request ;-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 570787
You need to log in before you can comment on or make changes to this bug.