crash [@ openMailWindow ]

RESOLVED FIXED in Thunderbird 3.3a1

Status

MailNews Core
Backend
--
blocker
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Bruno 'Aqualon' Escherl, Assigned: Bruno 'Aqualon' Escherl)

Tracking

({crash, regression})

Trunk
Thunderbird 3.3a1
x86
Windows XP
crash, regression

Thunderbird Tracking Flags

(thunderbird3.1 .4-fixed, thunderbird3.0 .9-fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100829 SeaMonkey/2.1b1pre (built from http://hg.mozilla.org/mozilla-central/rev/414ff9016349) crashes.

After new mail arrived and I get the notification, a crash occurs in two cases:

1. Clicking on the tray icon: bp-832c9be7-cac0-405c-a98e-bc86c2100830
2. Clicking on the new mail link in notification box: bp-f9261deb-8cbb-4359-90e6-6e7972100830

Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100825 SeaMonkey/2.1b1pre works fine. Could be fallout from bug 556114.

Perhaps also related with bug 591814, but no crash there.
(Assignee)

Comment 1

7 years ago
After the ftp-server was generous enough to let me download another build I can say, that Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100826 SeaMonkey/2.1b1pre works too.

I can't test a build from 20100827 and 20100828, since there are none due to tinderbox build bustage.
Keywords: crash
(Assignee)

Comment 2

7 years ago
Created attachment 471226 [details] [diff] [review]
remove shadowing nsCOMPtr

The nsCOMPtr shadows our real domWindow, which we get in http://mxr.mozilla.org/comm-central/source/mailnews/base/src/nsMessengerWinIntegration.cpp?mark=148-149#137
Assignee: nobody → aqualon
Status: NEW → ASSIGNED
Attachment #471226 - Flags: superreview?(bugzilla)
Attachment #471226 - Flags: review?(bugzilla)

Comment 3

7 years ago
Comment on attachment 471226 [details] [diff] [review]
remove shadowing nsCOMPtr

r+sr=me as my review on bug 556114 was conditional on this change anyway.
Attachment #471226 - Flags: superreview?(bugzilla)
Attachment #471226 - Flags: superreview+
Attachment #471226 - Flags: review?(bugzilla)
Attachment #471226 - Flags: review+
Component: OS Integration → Backend
Product: SeaMonkey → MailNews Core
QA Contact: os-integration → backend
Keywords: checkin-needed
Pushed http://hg.mozilla.org/comm-central/rev/6c659497d5b4
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Comment on attachment 471226 [details] [diff] [review]
remove shadowing nsCOMPtr

Will need this alongside the other bug for 3.x security releases.
Attachment #471226 - Flags: approval-thunderbird3.1.4?
Attachment #471226 - Flags: approval-thunderbird3.0.8?
Attachment #471226 - Flags: approval-thunderbird3.1.4? → approval-thunderbird3.1.4+
Checked into 1.9.2: http://hg.mozilla.org/releases/comm-1.9.2/rev/401e4867f0c5
status-thunderbird3.1: --- → .4-fixed
Also checked into relbranch: http://hg.mozilla.org/releases/comm-1.9.2/rev/401e4867f0c5
Target Milestone: --- → Thunderbird 3.3a1
(In reply to comment #7)
> Also checked into relbranch:
> http://hg.mozilla.org/releases/comm-1.9.2/rev/401e4867f0c5

Make that http://hg.mozilla.org/releases/comm-1.9.2/rev/75a65749863c on the relbranch.
Attachment #471226 - Flags: approval-thunderbird3.0.8? → approval-thunderbird3.0.9+
Checked into 1.9.1: http://hg.mozilla.org/releases/comm-1.9.1/rev/fd93f3f9f6d9
status-thunderbird3.0: --- → .9-fixed
Crash Signature: [@ openMailWindow ]
You need to log in before you can comment on or make changes to this bug.