Closed Bug 592622 Opened 10 years ago Closed 10 years ago

[Firefox Menu] Rename "Developer" Menu to "Web Developer" menu

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0b7
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: wladow, Assigned: u88484)

References

Details

(Whiteboard: [strings][has patch])

Attachments

(1 file, 2 obsolete files)

i6 mockup of the Firefox Menu [1] shows "Developer Tools" label for the dev submenu while the current implementation is using "Developer". We should rename that to match the mockup.

[1] https://bugzilla.mozilla.org/attachment.cgi?id=465479
Attached patch rename it (obsolete) — Splinter Review
Attachment #471070 - Flags: ui-review?(faaborg)
Attachment #471070 - Flags: review?(dao)
Attachment #471070 - Flags: review?(dao) → review+
blocking2.0: --- → ?
Whiteboard: [strings]
Comment on attachment 471070 [details] [diff] [review]
rename it

Moving this ui-r to Limi since he's been UX on dev tools stuff. Not convinced that this blocks, Limi - what do you think?
Attachment #471070 - Flags: ui-review?(faaborg) → ui-review?(limi)
Comment on attachment 471070 [details] [diff] [review]
rename it

I prefer Developer Tools too.
Attachment #471070 - Flags: ui-review?(limi) → ui-review+
Duplicate of this bug: 596121
Attachment #471070 - Flags: approval2.0?
See also bug 596121. "Developer" confuses people who need to change the character encoding as part of their normal browsing, for instance.
blocking2.0: ? → beta7+
Attachment #471070 - Flags: approval2.0?
That menu is for Developer Tools — "Advanced Tools" is so non-descript as to be useless, in my opinion. 

I think the solution for the charset stuff is to pull it out to the top level for the 2-3 locales where it's seeing active use, and leave it for the developers everywhere else.

(and why is this not a dupe of bug 596121?)
(In reply to comment #6)
> (and why is this not a dupe of bug 596121?)

Nevermind, that's what I get for not checking the current state on Windows, I guess. :P

Recommendation is still "Developer Tools" for this menu.
Just chatted with Faaborg and he asserted "no strong preference" but also argued that "Tools" doesn't really add much semantic content to this menu item. Can I get the two Alexes to bring this one to a close in, say, the next hour?
At the risk of churn/bikeshedding, why not just "Tools"? That's what they are, keeps consistency with previous Tools menu (for items that aren't already in the main UI) and keeps the label nice and short.
Duplicate of this bug: 596121
Morphing, slightly, to encompass bug 596121 and depend on bug 596173. The issues are:

 - will this menu include Character Encoding
 - do we need to call out that these are "tools" or "developer" specific tools

To be resolved and fixed by EOD, or I will eat someone's hat. Maybe mine, but that would require that I purchase and then eat a hat.
Blocks: 596173
Summary: [Firefox Menu] Rename "Developer" to "Developer Tools" → [Firefox Menu] Decide on name for "Developer" menu (Developer Tools / Tools / Advanced)
Comment on attachment 471070 [details] [diff] [review]
rename it

Revoking review due to latest developments (see bug 596121).
Attachment #471070 - Flags: review+
I'm leaning towards "Tools". It's less specific and potentially a catch-all, but it is a relatively common menu name. "Developer Tools" feels too long. I'd prefer a one-word name.
Limi's objection to "Tools" is that it will get filled with the same sort of content as the current "Tools" menu, which tends to not be as focused on web developers. I can understand that.

The menu is meant to be the home for tools for web developers, and perhaps even Mozilla developers in nightly versions (would be a good place for NTT to hang its hat, for example!). I actually think that this might be best as "Web Developer", especially with bug 596173 being resolved and pulling Character Encoding out of this menu.

I'll work up a patch (unless Vlado beats me to it!)
Status: ASSIGNED → NEW
Attached patch Patch (obsolete) — Splinter Review
Rename "Developer" to "Web Developer"
Assignee: wladow → supernova00
Attachment #471070 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #476928 - Flags: ui-review?(beltzner)
Attachment #476928 - Flags: review?(dao)
Comment on attachment 471070 [details] [diff] [review]
rename it

># HG changeset patch
># User Vlado Valastiak <wladow@gmail.com>
># Date 1283332385 -7200
># Node ID e43efae3ebe052f26a8ffefa702904b322dfe59c
># Parent  f47972d054732237620655bd77d19e831d2efe19
>Bug 592622 - [Firefox Menu] Rename "Developer" to "Developer Tools"

Sorry, I forgot to change the commit message and actually don't know how to.
Attached patch Patch v2Splinter Review
Rename 'Developer' to 'Web Developer' with correct commit message
Attachment #476928 - Attachment is obsolete: true
Attachment #476932 - Flags: ui-review?(beltzner)
Attachment #476932 - Flags: review?(dao)
Attachment #476928 - Flags: ui-review?(beltzner)
Attachment #476928 - Flags: review?(dao)
Comment on attachment 476932 [details] [diff] [review]
Patch v2

r+uir=beltzner
Attachment #476932 - Flags: ui-review?(beltzner)
Attachment #476932 - Flags: ui-review+
Attachment #476932 - Flags: review?(dao)
Attachment #476932 - Flags: review+
I believe this is now checkin-needed. Thanks, folks!
Keywords: checkin-needed
Whiteboard: [strings] → [strings][has patch][can land]
Summary: [Firefox Menu] Decide on name for "Developer" menu (Developer Tools / Tools / Advanced) → [Firefox Menu] Rename "Developer" Menu to "Web Developer" menu
Comment on attachment 476932 [details] [diff] [review]
Patch v2

I've yet to see a single argument why hiding "Work Offline" in a [Web] Developer menu is acceptable for people who need to uncheck it because Firefox thinks it's offline when it shouldn't be.
Attachment #476932 - Flags: review-
This is why I didn't want bug 596121 to be a duplicate of this one, btw. They are motivated differently.
Keywords: checkin-needed
Whiteboard: [strings][has patch][can land] → [strings][has patch]
dao: the focus of this bug in particular is just to rename the menu itself. If we need to reposition items within the menus, those can and should be separate. Maybe create a separate issue for this so we can get the string in?
(In reply to comment #22)
> dao: the focus of this bug in particular is just to rename the menu itself.

... to something that labels the content appropriately, which "Web Developer" doesn't as far as bug 596121 is concerned. Moving "Work Offline" elsewhere would be an option, but I haven't heard that we actually want that.
I don't think "Work Offline" is necessarily a "Web Developer" feature. It's a general purpose, I'm unplugging this browser from the internet kind of thing. Created bug 598310 for this.
(In reply to comment #24)
> I don't think "Work Offline" is necessarily a "Web Developer" feature. It's a
> general purpose, I'm unplugging this browser from the internet kind of thing.
> Created bug 598310 for this.

Ok, somebody needs to confirm that bug 598310, i.e. moving "Work Offline", is the route we want to take. I take it that we put it in this menu because we didn't want it to be a top-level item -- which might be a questionable goal given the outcome of bug 593125.
No longer blocks: 598310
Depends on: 598310
Yes, we want "work offline" as a web developer menu feature - that's fine, we know it will ruffle feathers, that's fine.
(In reply to comment #26)
> we know it will ruffle feathers, that's fine.

I assume this refers to the broken auto-recovery from offline mode? Do we have a sense of how many users are affected by this? Is the idea that they'll find the menu item anyway without trouble?

(As a former web developer I don't see why I would use "Work Offline", but that's a different question, which I care less about.)
Comment on attachment 476932 [details] [diff] [review]
Patch v2

I think I made my case clear, will leave it to others to do the right thing here.
Attachment #476932 - Flags: review-
>As a former web developer I don't see why I would use "Work Offline"

The theory is that you only need this because you are running your own local server.  It's a bit more complicated in that when we assume you are a Web developer who pays for minute based internet access, so on some level we are just dumping this control in the developer menu to obfuscate it until it can be removed.
(In reply to comment #29)
> It's a bit more complicated in that when we assume you are a Web
> developer who pays for minute based internet access,

I think I also said why this isn't a sane assumption...
"Work Offline" isn't only used by users who want to work offline. You need to uncheck it when Firefox is stuck in offline mode because your connection died a while ago or something.
Dao's point is that we have bugs (mostly on Linux, I think) that puts Firefox in offline mode without user interaction, and the only workaround is to undo that manually. Normal users affected by this bug would not think to look under the "Web Developer" menu for this option.

I don't see how local web servers or by-the-minute internet connections are relevant to this at all.
(That's a discussion that can be had in bug 598310, though - I don't think there's any reason to hold up this bug for it.)
(In reply to comment #31)
> Dao's point is that we have bugs (mostly on Linux, I think) that puts Firefox
> in offline mode without user interaction, and the only workaround is to undo
> that manually.

I've seen it happen yesterday and the day before yesterday on Win XP, fwiw.
Pushed http://hg.mozilla.org/mozilla-central/rev/13b48c1672c5
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b7
>Dao's point is that we have bugs (mostly on Linux, I think) that puts Firefox
>in offline mode without user interaction, and the only workaround is to undo
>that manually. Normal users affected by this bug would not think to look under
>the "Web Developer" menu for this option.

Right, and that's a very legitimate concern (I haven't hit these bugs myself, although I have heard about them).  The solution to that needs to be fixing the bugs. Having a "don't be broken" button in the main menu isn't a very good option.
(In reply to comment #14)
> Limi's objection to "Tools" is that it will get filled with the same sort of
> content as the current "Tools" menu, which tends to not be as focused on web
> developers.

You are the creators of Firefox - you can control how this menu evolves! Besides, web-developers tend to be particularly savvy people who will usually know an interface inside-out within 10 minutes and can easily pick out what is relevant to them, therefore I don't think developers are really in such a desperate need for their own dedicated interface area.

The placement of one menu item tends to affect another, so whatever you decide make sure the partitioning of the menu provides the cleanest, simplest, and most logical partitioning for the average user (just look at IE9's new "File" sub-menu to see how this can go horribly wrong! :)). My vote (in this non-democracy :)) is with the simple "Tools". 

(If you really want to make it developer-specific then I also think that prefixing "Developer" with "Web" just makes the name longer without adding any extra meaning. IMO "Developer" was fine as it was for this purpose - "Developer" menus are also common throughout other software such as MS Office!)
(In reply to comment #35)
> >Dao's point is that we have bugs (mostly on Linux, I think) that puts Firefox
> >in offline mode without user interaction, and the only workaround is to undo
> >that manually. Normal users affected by this bug would not think to look under
> >the "Web Developer" menu for this option.
> 
> Right, and that's a very legitimate concern (I haven't hit these bugs myself,
> although I have heard about them).  The solution to that needs to be fixing the
> bugs. Having a "don't be broken" button in the main menu isn't a very good
> option.

I never said it would be a good option. It's the only option currently. I assume you are aware of the relevant bugs and made sure they block the release before deciding to obfuscate the menu item?
With regard to the placement of "Work Offline", I think that Opera 10.6's organization is much more logical. i.e. Rename the sub-menu that you have called "Options..." to "Settings" and put it in there. Then rename "Options..." to "Preferences...". Sub-group all the other toolbar-related options under "Toolbars".
(In reply to comment #36)
> therefore I don't think developers are really in such a
> desperate need for their own dedicated interface area.

Actually, scratch what I said there in comment 36. Opera puts "Page Info" under its "Developer Tools" sub-menu. This is a good place to put it (rather than dropping it completely!).

If you clean out non-developer specific options like Work Offline (move to "Settings") and Character Encoding (move to top-level), then a developer-specific menu is fine. IMO "Developer Tools" did seem a better name in this situation than "Web Developer".
(In reply to comment #39)
> (In reply to comment #36)
> > therefore I don't think developers are really in such a
> > desperate need for their own dedicated interface area.
> 
> Actually, scratch what I said there in comment 36. Opera puts "Page Info" under
> its "Developer Tools" sub-menu. This is a good place to put it (rather than
> dropping it completely!).

aaaaaaghhhh - scratch that again!!! This is a nightmare! "Page info" also contains security tools that aren't really developer-specific either. "Page Info" more generally relates to the page. My preference goes back to just "Tools".
This bug is closed. Please stop spamming it.
Verified fixed with Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100923 Firefox/4.0b7pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.