Closed Bug 593294 Opened 9 years ago Closed 9 years ago

TM: various other defaultCompartment fixes

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: gwagner, Assigned: gwagner)

References

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 file, 1 obsolete file)

No description provided.
Assignee: general → anygregor
Attached patch patch (obsolete) — Splinter Review
Attachment #471774 - Flags: review?(mrbkap)
Comment on attachment 471774 [details] [diff] [review]
patch

Looks good. This is all rather harmless finalization stuff and xpcshell so I will +.
Attachment #471774 - Flags: review?(mrbkap) → review+
Comment on attachment 471774 [details] [diff] [review]
patch

>diff -r 8771ed0c60d8 js/src/xpconnect/shell/xpcshell.cpp
>--- a/js/src/xpconnect/shell/xpcshell.cpp	Thu Sep 02 14:52:18 2010 -0700
>+++ b/js/src/xpconnect/shell/xpcshell.cpp	Thu Sep 02 14:56:20 2010 -0700
>@@ -1963,17 +1963,17 @@ main(int argc, char **argv)
> 
>         rv = holder->GetJSObject(&glob);
>         if (NS_FAILED(rv)) {
>             NS_ASSERTION(glob == nsnull, "bad GetJSObject?");
>             return 1;
>         }
> 
>         JS_BeginRequest(cx);
>-
>+        JSAutoEnterCompartment ac(cx, glob);
>         if (!JS_DefineFunctions(cx, glob, glob_functions)) {

Doesn't this want to be an AutoCrossCompartmentCall?
Can't hurt. Gregor want to change that?
Attached patch patchSplinter Review
I had to scope the JSAutoCrossCompartmentCall otherwise it asserts during deconstruction because there is no more context.
Attachment #471774 - Attachment is obsolete: true
Attachment #471932 - Flags: review?(gal)
Blocks: 594455
review ping
Comment on attachment 471932 [details] [diff] [review]
patch

Undo the unrelated indentation changes please.
Attachment #471932 - Flags: review?(gal) → review+
http://hg.mozilla.org/tracemonkey/rev/0fadb2696554
Whiteboard: fixed-in-tracemonkey
Duplicate of this bug: 594181
http://hg.mozilla.org/mozilla-central/rev/0fadb2696554
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.