Closed Bug 593408 Opened 9 years ago Closed 9 years ago

Don't show file picker for Save Image, Save Link

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: wesj, Assigned: wesj)

References

Details

Attachments

(1 file)

The Save Image and Save Link context menu commands open up the default file picker. We probably just shouldn't ask at all.
Attachment #471916 - Flags: review?(mark.finkle)
We'll need to update testcases in our OS Integration TestGroup within Litmus once this lands.
Flags: in-litmus?
tracking-fennec: --- → ?
OS: Mac OS X → All
Hardware: x86 → All
Comment on attachment 471916 [details] [diff] [review]
Don't show the file picker

We need to make sure we communicate this change. I think it is a good change, but others might have other feedback.
Attachment #471916 - Flags: review?(mark.finkle) → review+
Whiteboard: [fennec-checkin-postb1]
tracking-fennec: ? → 2.0b2+
Duplicate of this bug: 580979
Assignee: nobody → wjohnston
pushed:
http://hg.mozilla.org/mobile-browser/rev/cc2cefb3dbde
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fennec-checkin-postb1]
Verified fixed:
Build Id:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b7pre) Gecko/20100930 Namoroka/4.0b7pre
Fennec/4.0b2pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b7pre) Gecko/20100930
Namoroka/4.0b7pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus?(ayanshah62)
Litmus test case added:

https://litmus.mozilla.org/show_test.cgi?id=13664
Flags: in-litmus?(ayanshah62) → in-litmus+
You need to log in before you can comment on or make changes to this bug.