Last Comment Bug 593538 - Hide the Error Console behind a preference
: Hide the Error Console behind a preference
Status: VERIFIED FIXED
[kd4b6]
: dev-doc-complete, relnote
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: All All
-- normal (vote)
: Firefox 4.0b7
Assigned To: Rob Campbell [:rc] (:robcee)
:
: Jared Wein [:jaws] (please needinfo? me)
Mentors:
Depends on: 601201
Blocks: 596249 596800 devtools4b7 597842
  Show dependency treegraph
 
Reported: 2010-09-03 19:31 PDT by Kevin Dangoor
Modified: 2010-10-05 04:05 PDT (History)
13 users (show)
mozillamarcia.knous: in‑litmus+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta7+


Attachments
Error Console Pref (3.58 KB, patch)
2010-09-07 10:55 PDT, Rob Campbell [:rc] (:robcee)
gavin.sharp: review-
Details | Diff | Splinter Review
Error Console showInConsole (3.06 KB, patch)
2010-09-07 11:34 PDT, Rob Campbell [:rc] (:robcee)
dtownsend: review-
Details | Diff | Splinter Review
Error Console Rename (999 bytes, patch)
2010-09-07 11:38 PDT, Rob Campbell [:rc] (:robcee)
gavin.sharp: review-
Details | Diff | Splinter Review
Error Console showInConsole->true (1023 bytes, patch)
2010-09-08 07:41 PDT, Rob Campbell [:rc] (:robcee)
dtownsend: review+
Details | Diff | Splinter Review
[checked-in] Error Console Pref + showInConsole (4.47 KB, patch)
2010-09-09 12:50 PDT, Rob Campbell [:rc] (:robcee)
gavin.sharp: review+
Details | Diff | Splinter Review
[checked-in] Error Console Key (797 bytes, patch)
2010-09-10 08:01 PDT, Rob Campbell [:rc] (:robcee)
dao+bmo: review+
Details | Diff | Splinter Review

Description User image Kevin Dangoor 2010-09-03 19:31:21 PDT
In Firefox 4, we plan to ship the new "Web Console" tool that helps developers troubleshoot content errors, which will meet the needs of most developers.

Firefox and add-on developers rely on the Error Console to debug chrome errors (after they've set the javascript.options.showInConsole = true pref). The existence of the Error Console next to the Web Console on the menu will be confusing to typical users.

There are three parts to this change:

1. Rename the Error Console to (bikeshed painting time): Browser Console, Chrome Error Console, Chrome Console

2. create a browser.enableChromeDeveloperTools pref which defaults to false and determines whether or not the Error Console appears in the menu. Ideally, the javascript.options.showInConsole value should be migrated into this new pref (so users that previously had it turned on will see the new menu item right away).

3. Remove the javascript.options.showInConsole pref


This needs to be done in beta 6.
Comment 1 User image Rob Campbell [:rc] (:robcee) 2010-09-07 07:28:16 PDT
taking...
Comment 2 User image Rob Campbell [:rc] (:robcee) 2010-09-07 10:55:13 PDT
Created attachment 472685 [details] [diff] [review]
Error Console Pref

responds to: browser.devtools.errorconsole.enabled.

Browser must be restarted for changes to take effect.
Comment 3 User image Rob Campbell [:rc] (:robcee) 2010-09-07 11:22:40 PDT
(In reply to comment #0)
> In Firefox 4, we plan to ship the new "Web Console" tool that helps developers
> troubleshoot content errors, which will meet the needs of most developers.
> 
> Firefox and add-on developers rely on the Error Console to debug chrome errors
> (after they've set the javascript.options.showInConsole = true pref). The
> existence of the Error Console next to the Web Console on the menu will be
> confusing to typical users.
> 
> There are three parts to this change:
> 
> 1. Rename the Error Console to (bikeshed painting time): Browser Console,
> Chrome Error Console, Chrome Console

I'd recommend Browser Console, I think. The menu options should be pretty distinct then, e.g., Browser Console vs. Web Console.

> 2. create a browser.enableChromeDeveloperTools pref which defaults to false and
> determines whether or not the Error Console appears in the menu. Ideally, the
> javascript.options.showInConsole value should be migrated into this new pref
> (so users that previously had it turned on will see the new menu item right
> away).

From my patch above, I created browser.devtools.errorconsole.enabled. I guess we could migrate this to browser.devtools.browserconsole.enabled.

> 3. Remove the javascript.options.showInConsole pref

tbd.
Comment 4 User image Rob Campbell [:rc] (:robcee) 2010-09-07 11:34:43 PDT
Created attachment 472699 [details] [diff] [review]
Error Console showInConsole

Removes showInConsole code and pref. No longer needed.
Comment 5 User image Rob Campbell [:rc] (:robcee) 2010-09-07 11:38:06 PDT
Created attachment 472701 [details] [diff] [review]
Error Console Rename

Changed Error Console to Browser Console in browser.dtd. Left references in code as-is.
Comment 6 User image Dave Townsend [:mossop] 2010-09-07 15:03:45 PDT
Comment on attachment 472699 [details] [diff] [review]
Error Console showInConsole

I don't think we should be removing support for this pref from all applications. Seems like you just want to make Firefox default to true.
Comment 7 User image Rob Campbell [:rc] (:robcee) 2010-09-08 07:41:40 PDT
Created attachment 473049 [details] [diff] [review]
Error Console showInConsole->true
Comment 8 User image Johnathan Nightingale [:johnath] 2010-09-08 08:49:01 PDT
I think this is important to the webconsole being a successful (and unambiguous!) feature - marking this blocking beta6 so that we have a coherent story at feature freeze.
Comment 9 User image Dave Townsend [:mossop] 2010-09-08 09:40:06 PDT
Comment on attachment 473049 [details] [diff] [review]
Error Console showInConsole->true

I'm technically not a browser peer but I suspect this is fine
Comment 10 User image Rob Campbell [:rc] (:robcee) 2010-09-08 12:35:15 PDT
(In reply to comment #9)
> Comment on attachment 473049 [details] [diff] [review]
> Error Console showInConsole->true
> 
> I'm technically not a browser peer but I suspect this is fine

I figured since you did the first round on that piece, I'd just extend you the privilege. :)
Comment 11 User image Johnathan Nightingale [:johnath] 2010-09-08 14:20:49 PDT
Back you go, misplaced blocking flag
Comment 12 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2010-09-08 14:24:34 PDT
Comment on attachment 472701 [details] [diff] [review]
Error Console Rename

Need to change the entity name when you make a semantic change to it.
Comment 13 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2010-09-08 14:27:46 PDT
None of the patches in this bug really make this a "browser console", so the string change seems kind of wrong - it still will be mostly filled with web content errors in the common case. Given that we're hiding it, how about we just leave the name as-is?
Comment 14 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2010-09-08 14:29:21 PDT
Comment on attachment 472685 [details] [diff] [review]
Error Console Pref

This will throw, since that pref doesn't have a default value. We should just associate both the menuitem and the key with a <command> element and just disable/enable that, too.
Comment 15 User image Kevin Dangoor 2010-09-08 18:45:26 PDT
(In reply to comment #13)
> None of the patches in this bug really make this a "browser console", so the
> string change seems kind of wrong - it still will be mostly filled with web
> content errors in the common case. Given that we're hiding it, how about we
> just leave the name as-is?

The intention is to take care of bug 593540 soon as well, which will filter out the content errors from the Browser Console. (So, the Web Console is where you go for content errors...)
Comment 16 User image Rob Campbell [:rc] (:robcee) 2010-09-09 06:25:59 PDT
Well, we could get rid of that part of the bug. I kind of agree with Gavin that it's a pointless change to rename it in this case. It will still be an "Error Console".
Comment 17 User image Kevin Dangoor 2010-09-09 06:34:59 PDT
I'm not attached to Browser Console. I don't mind if "Error Console" stays that way.
Comment 18 User image Rob Campbell [:rc] (:robcee) 2010-09-09 12:50:11 PDT
Created attachment 473684 [details] [diff] [review]
[checked-in] Error Console Pref + showInConsole

updated patch. Made the logic more like the inspector pref patch in bug 593536. Changed the pref to devtools.errorconsole.enabled to be more consistent.
Comment 19 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2010-09-09 13:38:17 PDT
Comment on attachment 473684 [details] [diff] [review]
[checked-in] Error Console Pref + showInConsole

same comment about .hidden/.disabled. Should probably get explicit ui-review on both of these as well.
Comment 20 User image Rob Campbell [:rc] (:robcee) 2010-09-09 15:03:31 PDT
Comment on attachment 473684 [details] [diff] [review]
[checked-in] Error Console Pref + showInConsole

http://hg.mozilla.org/mozilla-central/rev/2aaeb42e51a6
Comment 21 User image u88484 2010-09-10 05:52:21 PDT
Verified fixed using hourly build Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100910 Firefox/4.0b6pre from cset cca361001fda

The error console is hidden tools menu.  Flipping the pref to true and then restarting Firefox shows the menu entry.
Comment 22 User image Dão Gottwald [:dao] 2010-09-10 05:55:11 PDT
The keyboard shortcut doesn't actually get enabled. Please back out or fix quickly.
Comment 23 User image Rob Campbell [:rc] (:robcee) 2010-09-10 07:21:39 PDT
will investigate...
Comment 24 User image Rob Campbell [:rc] (:robcee) 2010-09-10 07:22:15 PDT
I expect it has to do with setting .disabled = false instead of removing the attribute. I saw this with the inspector as well.
Comment 25 User image Rob Campbell [:rc] (:robcee) 2010-09-10 08:01:51 PDT
Created attachment 474054 [details] [diff] [review]
[checked-in] Error Console Key

fix for key enablement
Comment 26 User image Rob Campbell [:rc] (:robcee) 2010-09-10 08:32:55 PDT
Comment on attachment 474054 [details] [diff] [review]
[checked-in] Error Console Key

http://hg.mozilla.org/mozilla-central/rev/5c0a3f26e0ef
Comment 27 User image Marcia Knous [:marcia - use ni] 2010-09-10 11:09:09 PDT
I updated the Menu Litmus test case to reflect this change and disabled the other test cases related to Error Console.
Comment 28 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2010-09-11 13:29:04 PDT
Verified with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6pre) Gecko/20100911 Firefox/4.0b6pre
Comment 29 User image Eric Shepherd [:sheppy] 2010-09-12 22:50:17 PDT
This got documented when robcee's blog post went up a couple days ago.

Note You need to log in before you can comment on or make changes to this bug.