Providing pref observer listener to hide/show the menu

RESOLVED DUPLICATE of bug 596249

Status

enhancement
RESOLVED DUPLICATE of bug 596249
9 years ago
Last year

People

(Reporter: alice0775, Unassigned)

Tracking

Trunk
Firefox 4.0
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

After landing Bug 593538 - Hide the Error Console behind a preference,

I can not use Error Console in Safe mode any more.

Please Add a command line option for Error console to be enabled.
Alternative:
Please add pref observer to change state of the Error Console.
Does |firefox -safe-mode -jsconsole| start the error console?
(In reply to comment #2)
> Does |firefox -safe-mode -jsconsole| start the error console?
Oh, it works.

However, when i close the error console once,I can not open it again.
Providing pref observer listener to hide/show the menu is common way, isn't it?
Summary: Add command line option for Error console to be enabled → Providing pref observer listener to hide/show the menu
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
I'm able to get the error console to open repeatedly... but only if I select it from the menu (tools menu on the mac). The keyboard shortcut does not appear to be working, as Dao reports in the bug which hid the error console behind a pref.
> Providing pref observer listener to hide/show the menu is common way, isn't it?
True. But you can call firefox again with -jsconsole as long as you don't use -no-remote.
FWIW, you don't actually have to restart for this to take effect - this code runs on window creation, so you can just open a new window and use its menu to open the console, after flipping the pref.
No longer blocks: 593538
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 596249
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.