Closed Bug 593603 Opened 9 years ago Closed 9 years ago

UI turns black when going back from full screen mode or enabling the default theme

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 593219

People

(Reporter: dun900, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre

The user interface turns black when going back from full screen mode. It also happens when enabling the default theme after enabling a persona. 
It goes back to normal when maximizing or minimizing the window.

Reproducible: Always

Steps to Reproduce:
I:
1. Go to Addons manager, enable a persona.
2. Enable the default theme.

II:
1. Go to full screen mode
2. Go back to normal mode
Actual Results:  
The UI turns black until you maximize/minimize the window.
Version: unspecified → Trunk
I can't reproduce this. Perhaps this was already fixed in the new build?

Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b6pre) Gecko/20100904030923
Firefox/4.0b6pre
It seems to only happen when "layers.accelerate-all" is set to true in about:config .
Blocks: d3d9-layers
I'm still unable to reproduce it. If you haven't already, update your copy of Firefox.

Press Alt -> Help -> Check For Updates...
I checked and it found no new updates. I will see if it is a problem with an addon.
I've done some testing. 

1. I downloaded the latest nightly directly from the ftp to be sure. Didn't change anything.
2. Disabled all addons. No change.
3. Tried using a new profile. It seems there are two settings that must be changed to reproduce the bug. 

First you have to have "mozilla.widget.render-mode" set to -1(should be the default) or 6. "layers.accelerate-all" must be set to true.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 593219
No longer blocks: d3d9-layers
You need to log in before you can comment on or make changes to this bug.