[D3D9] Crash [@ mozilla::layers::ThebesLayerD3D9::DrawRegion:363]

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: mattwoodrow, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

We crashed on Talos windows xp with D3D9 enabled. Crash looks like CreateTexture fails and we hit a NULL pointer trying to call LockRect (line numbers are -5 for me)

http://tinderbox.mozilla.org/showlog.cgi?log=Birch/1283644013.1283644395.11327.gz&fulltext=1

MSDN doesn't list an reason as to why this call could fail, I'm guessing OOM, or invalid size request.
Blocks: d3d9-layers
This turns out to have been caused by a pre-reviewed version of a patch.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.