Addons Manager: Details page should not use XUL-based styles.

VERIFIED DUPLICATE of bug 631827

Status

()

defect
VERIFIED DUPLICATE of bug 631827
9 years ago
8 years ago

People

(Reporter: pjdkrunkt, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

()

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100905 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100905 Firefox/4.0b6pre

There are a handful of cases of hard-coded styles built into the Details page of the new Addons Manager which should be styled in CSS so that users and themers can manipulate them.  These include:

<radiogroup id="search-filter-radiogroup" orient="horizontal"  align="center" persist="value" value="local">

<scrollbox id="detail-view" flex="1" class="view-pane addon-view" orient="horizontal" pack="stretch" align="start">

<hbox id="detail-desc-container" align="end">

Reproducible: Always

Updated

9 years ago
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [good first bug]
Depends on: 593796
No longer depends on: 593796
Why do you need to manipulate those structural rules? We don't really do this anywhere else.
blocking2.0: ? → -
Reporter

Comment 2

9 years ago
Basically, themers would like the ability to rearrange the elements in the AOM freely to optimize space for users or to simple create a whole new look.  In the above examples:

"search-filter-radiogroup" orient="horizontal" - hardcodes the Search Filters in a horizontal layout so a theme could not choose to have them laid out vertically to save horizontal space.

"detail-desc-container" align="end" - hardcodes the box containing the Theme Preview and Description so that if a themer chooses to have them aligned vertically instead of horizontally (so the description sits under the preview), they will be pushed to the far right of the Details panel. 

If these styles were added either in CSS or as a binding, we could freely change them to give our users greater choice and flexibility.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: [good first bug]
Duplicate of bug: 631827
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.