Closed Bug 593879 Opened 9 years ago Closed 9 years ago

transparent Image with box-shadow and set Opacity causes large Outline on hover with accelerated Layers

Categories

(Core :: Graphics, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: symphonicheaven, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100906 Firefox/4.0b6pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100906 Firefox/4.0b6pre

Just noticed this about two days ago when I updated to the latest Minefield build (this issue doesn't occur in Firefox 3.6.x).

When you hover over one of the "inactive" images, Minefield shows a large black border around the image for a second or two, as well as when you move the cursor away.

I remember seeing some box-shadow fixes filed in lately, perhaps it's due to that?

Reproducible: Always

Steps to Reproduce:
1. Hover over any of the inactive images in "Top Video Game Content".
2. Watch the border around the image.
3. Watch again as you move the cursor away.
Actual Results:  
A black (semi-transparent?) border appears around the image briefly.

Expected Results:  
There should be no border.

Using the default theme.
Summary: Transparent image with box-shadow causes large outline onhover → Transparent image with box-shadow causes large outline on hover
I'd rather say it's because of the Combination of Hover Selectors and set Opacity.
http://www.greywyvern.com/?post=317 is a good Example of how several CSS3 Rules (border-radius, box-shadow, transform:rotate, text-shadow) combined with that are affected by (defect) accelerated Layers rendering.
Component: General → Graphics
OS: Windows 7 → Windows XP
Product: Firefox → Core
QA Contact: general → thebes
Summary: Transparent image with box-shadow causes large outline on hover → transparent Image with box-shadow and set Opacity causes large Outline on hover with accelerated Layers
Version: unspecified → Trunk
Blocks: d3d9-layers
blocking2.0: --- → ?
Attached image tooltips
tooltips on tbpl are a great way to reproduce.
Fixed within:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fa55e317302a&tochange=9aecc4392dad
=> Bug 596152
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Depends on: 596152
Resolution: --- → FIXED
blocking2.0: ? → betaN+
Keywords: regression
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.