Fennec on maemo5 crashes with MOZ_ACCELERATED=1

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
9 years ago
5 years ago

People

(Reporter: romaxa, Assigned: romaxa)

Tracking

Trunk
ARM
Maemo
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

9 years ago
MOZ_ACCELERATED=1 ./fennec -url about:buildconfig
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
Extensions: EGL_KHR_image EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_vg_parent_image EGL_NOKIA_texture_from_pixmap 0x45
Extensions length: 158
###!!! ABORT: X_GetGeometry: BadDrawable (invalid Pixmap or Window parameter): file /home/cltbld/build/mobile-trunk-maemo5-gtk/mozilla-central/toolkit/xre/nsX11ErrorHandler.cpp, line 190
###!!! ABORT: X_GetGeometry: BadDrawable (invalid Pixmap or Window parameter): file /home/cltbld/build/mobile-trunk-maemo5-gtk/mozilla-central/toolkit/xre/nsX11ErrorHandler.cpp, line 190


m-c: http://hg.mozilla.org/mozilla-central/rev/c3e21097bb78
m-b: http://hg.mozilla.org/mobile-browser/rev/aeb8aa5a377f
Duplicate of this bug: 607705
Assignee

Comment 2

9 years ago
Posted patch WIP1Splinter Review
This is fixing WEBGL EGL context init for Qt and GTK fennec on maemo5 (bug 607705)

TextureImage works only on maemo6 (working on maemo5 port)
Assignee: nobody → romaxa
Status: NEW → ASSIGNED
Assignee

Updated

9 years ago
Duplicate of this bug: 606098
Assignee

Updated

9 years ago
Depends on: 592464
Does this still happen?

Comment 5

9 years ago
Yes, this still happens with latest beta (b3?) from Dec 20, 2010 if running fennec from an X terminal with:

MOZ_ACCELERATED=1 fennec

Comment 6

9 years ago
4.0b4 no longer crashes on startup with MOZ_ACCELERATED=1, but of course layers.acceleration.disabled == TRUE.

Forcing acceleration enabled and passing MOZ_ACCELERATED=1 causes quite a few things to fail to work (like about:config is a blank page, and about:support doesn't show any items in the Graphics section, whereas without acceleration it showed 0/1 windows accelerated).  But it no longer crashes.
Assuming we don't care about this any more.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.