SVG and -moz-box-sizing do not interact well

NEW
Unassigned

Status

()

Core
SVG
7 years ago
3 years ago

People

(Reporter: jwatt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

618 bytes, text/html
Details
(Reporter)

Description

7 years ago
SVG and -moz-box-sizing do not interact well. The SVG "viewport" area should really be resized.
(Reporter)

Comment 1

7 years ago
Created attachment 472608 [details]
testcase
(Reporter)

Comment 2

7 years ago
Clicking in the testcase toggles between 'content-edge' and 'padding-edge'. The circle should scale down when the value is 'padding-edge' instead of its right and bottom being clipped away.
(Reporter)

Updated

7 years ago
(Reporter)

Updated

7 years ago
Blocks: 243412
(Reporter)

Updated

6 years ago
Duplicate of this bug: 400155
(Reporter)

Comment 4

6 years ago
Created attachment 593562 [details]
testcase

Testcase with 'viewBox' attribute. (The old testcase didn't have it, and so expecting scaling was wrong.) This testcase shows that box-sizing works fine.
Attachment #472608 - Attachment is obsolete: true

Comment 5

5 years ago
(In reply to Jonathan Watt [:jwatt] from comment #4)
> [...] This testcase shows that box-sizing works fine.

Status: invalid?
Works fine for me, too.
(Reporter)

Comment 7

5 years ago
A reftest regression test should be landed for this to be close. I'll write one next week if someone else doesn't do it first.

Comment 8

4 years ago
Removing dependency on bug 243412
(as we have no bug here, it shouldn't block dropping the -moz-prefix from box-sizing)
No longer blocks: 243412
Depends on: 1131812
No longer depends on: 1131812
You need to log in before you can comment on or make changes to this bug.