Closed Bug 594087 Opened 11 years ago Closed 11 years ago

layer manager continually reinitialized

Categories

(Core :: Graphics, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
Summary: layer manager continually reinitialized on os x → layer manager continually reinitialized on os x and linux
Summary: layer manager continually reinitialized on os x and linux → layer manager continually reinitialized
We removed this code on windows, this patch removes it everywhere else.
This fixes us continuously re-initing the layer manager when the toplevel window never gets a call of GetLayerManager() or the attributes are out of sync for some other reason.
Attachment #472713 - Flags: review?(vladimir)
Attachment #472713 - Attachment is obsolete: true
Attachment #472715 - Flags: review?(vladimir)
Attachment #472713 - Flags: review?(vladimir)
Duplicate of this bug: 593725
Does this mean that every (child-)widget gets its own layer manager? (Even plugin widgets?) If so, is that bad?
http://hg.mozilla.org/mozilla-central/rev/56ab59360559

Markus, every widget must have its own layer manager -- the issue was that there was confusion about who was deciding what kind of layer manager was created.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
I see, thanks.
You need to log in before you can comment on or make changes to this bug.