Closed Bug 594140 Opened 9 years ago Closed 9 years ago

window.open width/height parameters do not respect opener's CSS-pixel-to-device-pixel ratio

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: roc, Assigned: roc)

References

(Depends on 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

nsWindowWatcher::SizeOpenedDocShellItem computes devPixelsPerCSSPixel from the widget for the root chrome window. Instead it should be inspecting aParent's prescontext.
Attached patch fix (obsolete) — Splinter Review
Attachment #472790 - Flags: review?(tnikkel)
Attachment #472790 - Flags: review?(tnikkel) → review+
Oh, can you set the fullzoom back to 1 when you are done just in case?
Attached patch fix v2Splinter Review
Done
Attachment #472790 - Attachment is obsolete: true
Attachment #472809 - Flags: approval2.0?
Attachment #472790 - Flags: approval2.0?
I mention that because I once spent a ridiculous amount of time trying to track down a test failure that was caused by changing the zoom and not resetting it in a test.
Attachment #472809 - Flags: approval2.0? → approval2.0+
Keywords: checkin-needed
Whiteboard: [needs landing]
Depends on: 705156
Depends on: 779335
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.