Toolbar context menu displayed for page entries in history menu

RESOLVED DUPLICATE of bug 248963

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 248963
8 years ago
6 years ago

People

(Reporter: Himanshu, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME?])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b5) Gecko/20100101 Firefox/4.0b5
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

When I right click on any site in History from Menu Bar options Open, Open in New Tab, Open in New Window, etc doesn't appear rather Menu displaying options Menu Bar, Navigation Toolbar, Bookmarks Toolbar,Tabs on Top, Customize appears.
And When I right click on any site in History from Firefox Button, no right click menu appears.

And When I right click on any site in Bookmarks from Menu Bar or from Firefox Button, right click menu appears correctly but when I right click on another site from the Bookmarks menu that site is not highlighted like the previous one.

Reproducible: Always

Steps to Reproduce:
1.Go to History Menu 
2.Right Click on any Site, Menu Bar, Navigation Toolbar, Bookmarks Toolbar,Tabs on Top, Customize options appear
3.Go to Bookmarks Menu
4.Right click on any Site, that option is highlighted
5.Now right click on any other site, that option is not highlighted, rather the previous option still remained highlighted.
So this are the Bugs:

* a Regression against 3.5.x:
Right Click on an Item in History Menu (the old one) should not offer Toolbar Customization Options. In the new Button Menu this is solved.

It would be an Enhancement Request to offer Link/Bookmark Item Options on right Click.

* (second) right Click on a (new) Item in Bookmarks Menu (new or old one does not matter) should highlight this Item.

Not sure if these are already filed.
Severity: trivial → normal
Component: Bookmarks & History → Menus
QA Contact: bookmarks → menus
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
Anyone who is using firefox 4 Beta5 can try this if it happens to their browser then its a bug which must be fixed by firefox in next beta

Comment 3

8 years ago
Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

Following Steps to Reproduce, same issue occurs for me.

Comment 4

8 years ago
Images from this bug:

History:
http://i51.tinypic.com/1zh2o1f.jpg

Bookmarks (notice that while I have right-clicked MLB.com, ESPN is still highlighted):
http://i55.tinypic.com/nqxpoh.jpg
It's also happening with Namoroka so I wonder if this is an already known issue. Neil, are you aware of one?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [DUPEME?]

Comment 6

8 years ago
I'm sure this will be addressed, but under "platform" in the bug description it states x86 Windows XP. The bug is affecting me on Vista 64 bit.
(Reporter)

Comment 7

8 years ago
Images exactly shows what the problem is
(Reporter)

Comment 8

8 years ago
But I am on Windows XP
(Reporter)

Comment 9

8 years ago
I want to know whether firefox team is working on this or not because in Beta 6 there is no fix for this.
Severity: normal → critical
Can you check if the problem also exists with a Firefox 3.5.x build?
Severity: critical → normal

Comment 11

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.14) Gecko/20100930 Firefox/3.5.14

Yes, The problem is in 3.5.x versions also. Right click on any site in Bookmarks menu, it displays the option, but When i right click on the second site, bookmarks menu closes, displaying the right click option of the main firefox window.
Duplicate of this bug: 613453
Summary: Right Click Options Are Not Displayed Correctly → Toolbar context menu displayed for page entries in history menu

Comment 13

6 years ago
Bug 248963 is a duplicate

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 248963
You need to log in before you can comment on or make changes to this bug.