Closed Bug 594387 Opened 12 years ago Closed 12 years ago

[ANGLE] Resizing or Dragging the window locks up the browser while culling webgl demo is running

Categories

(Core :: Graphics: CanvasWebGL, defect)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 575515

People

(Reporter: scoobidiver, Unassigned)

References

()

Details

(Keywords: hang)

Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100908 Firefox/4.0b6pre

Steps to reproduce :
1. go to the ref URL
2. move the FF window
To exit the hang, CTRL+alt+supp is necessary.
During the demo and the moving, the CPU usage is constant : about 50%.

I don't think there is a link but, during the culling webgl demo load, the error console displays :
"A texture is going to be rendered as if it were black, as per the OpenGL ES 2.0.24 spec section 3.8.2, because it is a 2D texture, with a minification filter requiring a mipmap, and is not mipmap complete (as defined in section 3.7.10)."
Filed bug 594393 about the weird message. Unrelated.
I set webgl.shader_validator to false. Now FF does not hang.
So, I think it is a dupe of either bug 589268 or bug 594489.
Summary: Moving FF window while culling webgl demo is running causes a hang → Moving FF window while culling webgl demo is running causes a hang with shader validator ON
See bug 598166 comment 19 for a comment on shader bugs.
Depends on: 575515
Summary: Moving FF window while culling webgl demo is running causes a hang with shader validator ON → [ANGLE] Resizing or Dragging the window locks up the browser while culling webgl demo is running
Actually, these "hang while dragging the window" bugs, like for instance Bug 598166, are dupes of bug 575515.

The reason why ANGLE would make a difference is that ANGLE shader translator is CPU-intensive, and this bug is about CPU-intensive tasks disturbing the GUI main event loop in Windows.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
On bug 597416 URL, CPU usage is 60% and I don't have the hang issue.
With shader_validator ON, on the test URL, the CPU usage is 60% and I have the hang issue.
It is not necessarily an ANGLE bug, but the hang seems to be related to GPU.
I know that this is insanely confusing. You don't need to be at 100% for 5 seconds to get the hang. People have reported that just a firefox cold start (so, more IO-bound than CPU-bound) could trigger it. Perhaps all my point in my above comment was that all ANGLE did here was add some more load. But look at the discussion, and the successive testcases in Bug 598166. At the beginning everyone was convinced it was a GPU issue, but in the end the minimal test case is just doing a JS setInterval + loop...!
No longer depends on: 575515
Depends on: slowui
Blocks: slowui
No longer depends on: slowui
You need to log in before you can comment on or make changes to this bug.