Better, less confusing, messages when drawing with not-yet-uploaded textures

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: bjacob, Assigned: bjacob)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 473061 [details] [diff] [review]
Better, less confusing, messages when drawing with not-yet-uploaded textures

At least 3 different bug reports today (bug 594310, bug 594387, bug 594357) show puzzling messages about black textures in WebGL apps that look fine. The reason is that they draw typically using a timer and the timer ticks before they load the textures.

This patch detects textures with not-yet-loaded images at level 0 and prints a much more helpful message in this case.
Attachment #473061 - Flags: review?(vladimir)
Attachment #473061 - Flags: approval2.0?
Assignee: nobody → bjacob
Duplicate of this bug: 598497
Comment on attachment 473061 [details] [diff] [review]
Better, less confusing, messages when drawing with not-yet-uploaded textures

Please re-request approval once this patch has been reviewed
Attachment #473061 - Flags: approval2.0?
Attachment #473061 - Flags: approval2.0+
http://hg.mozilla.org/mozilla-central/rev/4062e59e5e8e
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.