Closed Bug 594509 Opened 10 years ago Closed 10 years ago

fix about:rights page for unbranded builds

Categories

(Toolkit Graveyard :: XULRunner, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla2.0b7

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(2 files, 2 obsolete files)

Attached patch fix (obsolete) — Splinter Review
A string id changed in aboutRights.xhtml when the about:rights content was updated in bug 514817, and it needs to be changed in aboutRights-unbranded.xhtml as well.
Attachment #473177 - Flags: review?(gavin.sharp)
Comment on attachment 473177 [details] [diff] [review]
fix

r=me, but please also remove lines 44 and 45 of toolkit/locales/en-US/chrome/global/aboutRights.dtd which were duplicated by the original checkin:

http://hg.mozilla.org/mozilla-central/rev/c8bf9ce70506#l2.31
Attachment #473177 - Flags: review?(gavin.sharp)
Attachment #473177 - Flags: review+
Attachment #473177 - Flags: approval2.0+
A simple test that checks that this page loads without parse errors would be good (just look for a set string in the body, e.g.).
Attached patch fix (take two) (obsolete) — Splinter Review
Attachment #473177 - Attachment is obsolete: true
Attachment #473185 - Flags: review?(gavin.sharp)
Attached patch fix (take two)Splinter Review
Attachment #473185 - Attachment is obsolete: true
Attachment #473186 - Flags: review?(gavin.sharp)
Attachment #473185 - Flags: review?(gavin.sharp)
Attachment #473186 - Flags: review?(gavin.sharp)
Attachment #473186 - Flags: review+
Attachment #473186 - Flags: approval2.0+
Attached patch testSplinter Review
Test to make sure content loads properly.
Attachment #473236 - Flags: review?(gavin.sharp)
Attachment #473236 - Flags: review?(gavin.sharp)
Attachment #473236 - Flags: review+
Attachment #473236 - Flags: approval2.0+
Keywords: checkin-needed
Duplicate of this bug: 594781
http://hg.mozilla.org/mozilla-central/rev/39fd9758c2d0
http://hg.mozilla.org/mozilla-central/rev/c966fbc9ffd4
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Keywords: checkin-needed
Target Milestone: --- → mozilla2.0b6
Flags: in-testsuite+
Version: unspecified → Trunk
Depends on: 595188
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.