Intermittent mochitest-ipcplugins failures: test_cocoa_focus.html | Test timed out then multiple failures in test_cocoa_window_focus.html

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: philor, Assigned: mounir)

Tracking

({intermittent-failure})

Trunk
All
Mac OS X
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1284087956.1284089580.4390.gz#err1
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test mochitest-other on 2010/09/09 20:05:56
s: talos-r3-snow-018

33 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_cocoa_focus.html | Test timed out.
37 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_cocoa_window_focus.html | Activation state should be: activated - got false, expected true
39 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_cocoa_window_focus.html | Activation state should be: activated - got false, expected true
42 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_cocoa_window_focus.html | Window focus event count should be 2 - got 1, expected 2
44 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_cocoa_window_focus.html | Window focus event count should be 2 - got 1, expected 2
45 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_cocoa_window_focus.html | Activation state should be: activated - got false, expected true
46 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_cocoa_window_focus.html | Window focus event count should be 3 - got 1, expected 3
47 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_cocoa_window_focus.html | Activation state should be: activated - got false, expected true
48 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/plugin/test/test_cocoa_window_focus.html | Window focus event count should be 3 - got 1, expected 3
Comment hidden (Treeherder Robot)
(Assignee)

Comment 2

7 years ago
Very likely caused by the change from bug 369306.
I will try to investigate that.
Assignee: nobody → mounir.lamouri
Hardware: x86_64 → All
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 51

7 years ago
Emu boots is popurlar increasingly as Ugg boots. They are genuine sheepskin boots. We have all the fashionable styles availably who can help you to got the cheap ugg boots!!
http://www.emu-boots.org/
Comment hidden (Treeherder Robot)
(Assignee)

Comment 53

7 years ago
Created attachment 477409 [details] [diff] [review]
Patch v1

Attempt to fix the orange.
Attachment #477409 - Flags: review?(jst)
(Assignee)

Updated

7 years ago
Status: NEW → ASSIGNED

Updated

7 years ago
Attachment #477409 - Flags: review?(jst) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 57

7 years ago
I think Steven Michaud has a modification for this test posted, cc'ing him.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to comment #57)

> I think Steven Michaud has a modification for this test posted,
> cc'ing him.

Yes I do, at bug 601182 (attachment 484147 [details] [diff] [review]).

But I don't think it's terribly likely to fix this bug.  And in any
case it can't land until the patch for bug 601182 also lands.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 76

7 years ago
Created attachment 486902 [details] [diff] [review]
Patch v1.1
Attachment #477409 - Attachment is obsolete: true
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 81

7 years ago
Fix pushed:
http://hg.mozilla.org/mozilla-central/rev/dab8e1613a67

I will wait a few days and if nothing appears, I will close it.
Comment hidden (Treeherder Robot)
(Assignee)

Comment 83

7 years ago
I was a bit to quick in my previous comment. The patch was pushed but some tests were still running without that patch. Now, no tests on mozilla-central should be running without that patch.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to comment #83)

Mounir:  Judging by the number of recent mozilla-central test failures, your patch doesn't seem to have fixed this bug.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 103

7 years ago
(In reply to comment #99)
> (In reply to comment #83)
> 
> Mounir:  Judging by the number of recent mozilla-central test failures, your
> patch doesn't seem to have fixed this bug.

Indeed. Even if some results come from the tryserver and tracemonkey which were not up to date.
I will try to have a look today to see if I can find something else.
(Assignee)

Comment 104

7 years ago
Created attachment 487607 [details] [diff] [review]
Patch 2

So, I've seen two issues here:
1. when focusing the main window back, I didn't use an event handler. This might not be a problem but the event handler is better for correctness.
2. the plugin also use an event handler to update its states so we need to be sure to not check them before the update. Using executeSoon() should fix that.

I hope this patch would be the one :)
Attachment #487607 - Flags: review?(jst)

Updated

7 years ago
Attachment #487607 - Flags: review?(jst) → review+
(Assignee)

Comment 105

7 years ago
Pushed the new fix:
http://hg.mozilla.org/mozilla-central/rev/f0129b7f9190

Marking the bug as fixed. I will reopen if the fix isn't working.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
(Reporter)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 107

7 years ago
Argh :(

Could that be the reason of this random orange:
2010-11-01 14:50:09.232 firefox-bin[544:903] Mozilla has caught an Obj-C exception [NSInternalInconsistencyException: Error (1000) creating CGSWindow]
NPP_Destroy
Mounir, you might want to try what I did in a revision of this test
which I haven't yet landed (attachment 484147 [details] [diff] [review], see bug 601182 comment
#21):

I got rid of 'onload="runTests()"' from the <body> tag and replaced it
with:

  window.opener.SimpleTest.waitForFocus(runTests, window);

When Josh first suggested my patch might fix this problem (in comment
#57 above) I didn't think this was likely.  Now I'm not so sure.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 174

7 years ago
Created attachment 490465 [details] [diff] [review]
Patch #3

Let's try with waitForFocus().
Attachment #490465 - Flags: review?(jst)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 178

7 years ago
Comment on attachment 490465 [details] [diff] [review]
Patch #3

The failure seems permanent or very frequent with this patch. I will check on a Mac what could be the cause. Canceling the review in the mean time.
Attachment #490465 - Flags: review?(jst)
(Assignee)

Comment 179

7 years ago
Created attachment 490544 [details] [diff] [review]
Patch #3
Attachment #490465 - Attachment is obsolete: true
Attachment #490544 - Flags: review?(jst)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

7 years ago
Attachment #490544 - Flags: review?(jst) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 185

7 years ago
Pushed:
http://hg.mozilla.org/mozilla-central/rev/68df5bb6da6c

Some MacOS X mochitests are still running on try without this patch applied.
Let's hope this patch will fix the issue.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
(Reporter)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 210

7 years ago
Ok, I think my last patch fixed this random orange.
After my patch, all failures are after "browser_relative.js" failing and this did not happen since a month even if bug 573259 (browser_relative intermittent) still happen. I think that, for some reason, bug 573259 no longer make this test failing.

Feel free to reopen if you do not agree.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Looks like comment 211 is this bug. I reopen this bug. If you don't think the log isn't this bug, please re-close this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 213

6 years ago
Obviously, comment 211 was a false positive.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
Keywords: intermittent-failure
Whiteboard: [orange]
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.