fastpath to get nsIUnicodeEncoder and nsIUnicodeDecoder

RESOLVED DUPLICATE of bug 919935

Status

()

enhancement
RESOLVED DUPLICATE of bug 919935
9 years ago
4 years ago

People

(Reporter: m_kato, Assigned: smontagu)

Tracking

(Blocks 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

nsIUnicodeEncoder and nsIUnicodeDecoder are non-scriptable interface.

Now, to get these interfaces, we have to get nsICharsetConverterManager service/interface, then we use GetUnicode* method to get these.

Since nsIUnicode* is noscript interface, we should add fastpath function to get these without getService().
We now have EncodingUtils::DecoderForEncoding and EncodingUtils::EncoderForEncoding. Duplicating forward to where they were implemented.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 919935
You need to log in before you can comment on or make changes to this bug.