Last Comment Bug 595292 - browser_394759.js seems to hit network with dns failures
: browser_394759.js seems to hit network with dns failures
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: Firefox 7
Assigned To: :Ehsan Akhgari (away Aug 1-5)
:
Mentors:
Depends on:
Blocks: 570192 626999 726521
  Show dependency treegraph
 
Reported: 2010-09-10 12:25 PDT by Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
Modified: 2012-03-09 09:17 PST (History)
5 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch (v1) (1.47 KB, patch)
2011-06-22 10:46 PDT, :Ehsan Akhgari (away Aug 1-5)
paul: review+
jst: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2010-09-10 12:25:50 PDT
At least when running the test locally. It doesn't cause failures, but we shouldn't do it.

It's because we try to go to windowN.example.com. Simon actually brought this up in review, and I said meh because it didn't actually matter.

But now it's annoying to see comcast's dns error page in tests, so I want to fix it.
Comment 1 :Ehsan Akhgari (away Aug 1-5) 2011-06-22 10:45:50 PDT
I bet this is actually the cause of bug 570192.  It might make the test time out because of DNS query timeout for example (in which case the load event won't fire, I think).  The fix is really simple, and I think it's worth taking.
Comment 2 :Ehsan Akhgari (away Aug 1-5) 2011-06-22 10:46:46 PDT
Created attachment 541106 [details] [diff] [review]
Patch (v1)
Comment 3 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-06-22 13:00:19 PDT
Comment on attachment 541106 [details] [diff] [review]
Patch (v1)

Review of attachment 541106 [details] [diff] [review]:
-----------------------------------------------------------------

I've been meaning to go back through and find bugs like this. Thanks for just doing it.
Comment 4 Mounir Lamouri (:mounir) 2011-06-23 02:33:56 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/b060d115f501
Comment 5 Jeff Walden [:Waldo] (remove +bmo to email) 2011-06-23 11:18:07 PDT
(In reply to comment #0)
comcast++ (!)
Comment 6 Matt Brubeck (:mbrubeck) 2011-06-23 14:36:13 PDT
Comment on attachment 541106 [details] [diff] [review]
Patch (v1)

Requesting mozilla-approval-aurora.  This is a one-line patch to prevent a test from requesting a remote page over the internet.  The test became permaorange starting yesterday because of some infrastructure change or external change, and is still permaorange on Aurora.  So far releng has not been able to figure out what might have changed to trigger the failures.  This patch has landed on mozilla-central so the test is no longer failing there.

Landing this test-only change on Aurora now will allow us to have green tests for Firefox 6 as it goes through Aurora, Beta, and Release.
Comment 7 Johnny Stenback (:jst, jst@mozilla.com) 2011-06-23 14:39:10 PDT
Comment on attachment 541106 [details] [diff] [review]
Patch (v1)

a=drivers for this test-only change.
Comment 8 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-06-23 15:04:49 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/3b5e85a40598
Comment 9 Virgil Dicu [:virgil] [QA] 2011-08-25 23:57:13 PDT
Hello.

Is there a way in which this issue can be verified? Some simple STR or a test case?

Note You need to log in before you can comment on or make changes to this bug.