The browser crashes after switching themes from Preferences dialog

VERIFIED DUPLICATE of bug 68208

Status

Core Graveyard
Skinability
P3
normal
VERIFIED DUPLICATE of bug 68208
18 years ago
10 years ago

People

(Reporter: Patty Mac, Assigned: Marc Attinasi)

Tracking

({crash})

Trunk
mozilla0.9
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Platform: Linux (Installer; Recommend in; 2000-11-08-07-MN6).

Steps to reproduce:

1. Go to sweetlou and get the installer, recommend-in, 2000-11-08-07-MN6
2. Creat a new profile name (ie, 11-08-07-MN6mmm)
3. Type this url: http://gooey/client/themes
4. Look for modern-mozillium theme and click the install button.
5. After the installation, go to view/apply theme...modern-mozillium.
6. Look for Early blue theme and click the install button.
7. After the installation, go to view/apply theme....Early Blue.
8. Look for PVSR theme and click the install button.
9. After the installation, go to view/apply theme...PVSR.
10. Look for grr-ly theme and click the install button.
11. After the installation, go to view/apply theme...grr-ly.
12. Go to Tasks/Address Book
13. Click the cancel button to ignore he Account Wizard dialog.
14. Go to Edit/Preferences/Themes/modern-mozillium from the Address Book dialog.
15. Continue to switching themes to Early Blue, PVSR, and grr-ly skins. The
browser eventually crashes. I can reproduce 2 out of three times.

Below here is the talkback report:
 Trigger Type:   Program Crash
<../images/spacer.gif>
Trigger Reason:  SIGSEGV: Segmentation Fault: (signal 11)
<../images/spacer.gif>
Call Stack:    (Signature = libgklayout.so + 0x2271d3 (0x40cef1d3) d74719ac)
     libgklayout.so + 0x2271d3 (0x40cef1d3)
     libgklayout.so + 0x319a3e (0x40de1a3e)
     libgklayout.so + 0x31bcbe (0x40de3cbe)
     libgklayout.so + 0x3209e1 (0x40de89e1)
     libgklayout.so + 0x31de91 (0x40de5e91)
     libgklayout.so + 0x31e2fd (0x40de62fd)
     libgklayout.so + 0x41e1d7 (0x40ee61d7)
     libgklayout.so + 0x21682b (0x40cde82b)
     librdf.so + 0x5ffca (0x4085dfca)
     libgklayout.so + 0x1da9e4 (0x40ca29e4)
     libgklayout.so + 0x1d7e4f (0x40c9fe4f)
     libgklayout.so + 0x1d563f (0x40c9d63f)
     libgklayout.so + 0x21746f (0x40cdf46f)
     libgklayout.so + 0x217372 (0x40cdf372)
     libgkview.so + 0x7b69 (0x410cbb69)
     libgkview.so + 0x7b0e (0x410cbb0e)
     libgkview.so + 0x7b0e (0x410cbb0e)
     libgkview.so + 0x104ce (0x410d44ce)
     libgkview.so + 0x751d (0x410cb51d)
     libwidget_gtk.so + 0x255fa (0x404d35fa)
     libwidget_gtk.so + 0x25525 (0x404d3525)
     libwidget_gtk.so + 0x25680 (0x404d3680)
     libwidget_gtk.so + 0x25a1d (0x404d3a1d)
     libwidget_gtk.so + 0x29b1f (0x404d7b1f)
     libwidget_gtk.so + 0x20557 (0x404ce557)
     libwidget_gtk.so + 0x2041a (0x404ce41a)
     libgdk-1.2.so.0 + 0x174db (0x406394db)
     libglib-1.2.so.0 + 0x10186 (0x40669186)
     libglib-1.2.so.0 + 0x10751 (0x40669751)
     libglib-1.2.so.0 + 0x108f1 (0x406698f1)
     libgtk-1.2.so.0 + 0x8c5b9 (0x4058e5b9)
     libwidget_gtk.so + 0x185fc (0x404c65fc)
     libnsappshell.so + 0x158da (0x4045f8da)
     mozilla-bin + 0x6185 (0x0804e185)
     mozilla-bin + 0x65a6 (0x0804e5a6)
     libc.so.6 + 0x189cb (0x4025f9cb)
<../images/spacer.gif>

Comment 1

18 years ago
*** Bug 59644 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Keywords: crash

Comment 2

17 years ago
Pretriage of skinnability bugs, marking nsbeta1
Keywords: nsbeta1
--> crash in layout, so to karnaze
Assignee: ben → karnaze

Comment 4

17 years ago
Attinasi, this could be a dup of bug 68208.
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 5

17 years ago
This is not crashing after my patch for bug 70648 - marking as a dup of bug
68208 since that one covers the same problem as exposed by changing prefs.

*** This bug has been marked as a duplicate of 68208 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

17 years ago
Sorry, I put the wrong bug number: lemme try again.

This is not crashing after my patch for bug 73553 - marking as a dup of bug
68208 since that one covers the same problem as exposed by changing prefs.
(Reporter)

Updated

17 years ago
QA Contact: blakeross → pmac

Comment 7

17 years ago
Lots of verifications.

If I had to test stuff, it was on Win2K, build id 2001052404.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.