Closed Bug 595472 Opened 11 years ago Closed 11 years ago

Opening a .diff mail attachment causes seamonkey to spawn new windows at 2/sec.

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 167320

People

(Reporter: andyqos, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.12) Gecko/20100825 SeaMonkey/2.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.12) Gecko/20100825 SeaMonkey/2.0.7

Seamonkey on a barebones LFS setup, no desktop installed, window manager is oldish metacity.

In line attachments are turned off.

Reproducible: Always

Steps to Reproduce:
1.double click/right click and open a mail attachment with a .diff suffix.
2.
3.
Actual Results:  
Save dialogue window will appear but immediately browser windows will start spawning at a rate of 2/sec. They will not stop until seamonkey is killed.
Upon restarting seamonkey the extra windows are not restored but "real" windows that were running before the bug was triggered will be.

Expected Results:  
save dialogue

No gui editors installed, or associations made for .diff.
what is the mime-type for this attachment ?
(look in the email source)
(In reply to comment #1)
> what is the mime-type for this attachment ?
> (look in the email source)

text/plain. 

I just did a quick test -

echo hello > hello.diff
echo hello > hello.patch
echo hello > hello.c
echo hello > hello.txt

mailed them to my self as attachments and all of them open OK and display "hello" in a browser window apart from .diff which still triggers the bug.

Though I stated above that I don't have editors/desktop installed I guess in theory I could have some baggage around from previous setups long ago, as whenever I build a new LFS I copy over my ~/.mozilla to the new system.

It was a long time ago since I last did that - early seamonkey 1.x I guess.
I would be suprised if this bug has always been present on this setup without me hitting it before now, but then...
(In reply to comment #2)
> (In reply to comment #1)
> > what is the mime-type for this attachment ?
> > (look in the email source)
> 
> text/plain. 

Oops - I was wrong - I did look at a "real" mail with a .diff and must have missed it.

Using my test mail I can see that the .diff is 

Content-Type: text/x-diff

Whereas the others are text/plain
(In reply to comment #3)
>
> Using my test mail I can see that the .diff is 
> 
> Content-Type: text/x-diff
> 
> Whereas the others are text/plain

Did a bit more testing today - I backed up and deleted my .mozilla and repeated my test attachments.

They all came through as text/plain and displayed OK inline.

For some reason I failed to find the switch to turn off in line display of attachments so I couldn't test like for like.
(In reply to comment #4)

> For some reason I failed to find the switch to turn off in line display of
> attachments so I couldn't test like for like.

I found the setting and using my .mozilla the .diff will display OK inline.

In the deleted .mozilla case both inline and not inline cases work, but then .diff is text/plain vs text/x-diff.
(In reply to comment #5)
> (In reply to comment #4)

> In the deleted .mozilla case both inline and not inline cases work, but then
> .diff is text/plain vs text/x-diff.

Further investigation shows that I has diff setup to use seamonkey as a helper application.

Changing this to download, of course fixes the issue. But I guess it still counts as a bug that seamonkey will spawn and spawn new windows if set to open diff.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 167320
You need to log in before you can comment on or make changes to this bug.